3 Replies Latest reply on Apr 8, 2018 8:42 PM by gener7

    Shortcut problem with secondary key characters (Windows 10)

    LeRichie

      Ok, this is driving me crazy. I use Adobe CC in OSX and Windows 10.

       

      In OSX everything works fine, my workflow is smooth; but on Windows I always have problems with shortcuts.

      I use Spanish keyboard scheme on both of my computers, some Primary characters like "semicolon" are secondary characters in a spanish keyboard.

       

      In Mac, when I try to Hide/Show Guides in photoshop using  Ctrl+; (Default shortcut) I need to press Ctrl+Shift+(semicolon key)  because the semicolon is a secondary character on his key and it works perfectly, all my secondary keys work perfectly with Shift as trigger for the second character, but in windows it doesn't work.

       

      My Photoshop shortcuts are the default ones, everything is exactly the same, but Photoshop (or maybe Windows) don't let me trigger shortcuts with secondary characters.

       

      Anyone here have or had the same problem, any tip to solve this? I will appreciate the help

        • 1. Re: Shortcut problem with secondary key characters (Windows 10)
          gener7 Adobe Community Professional & MVP

          You can use Edit > Keyboard Shortcuts to set up a convenient custom shortcut and save it as a Custom keyboard shortcut file separate from the default set.

           

          I use OSX as shown in the screenshot, but idea is the same. Perhaps use the primary character if it's not taken.

           

          Gene

           

          Screen Shot 2018-04-08 at 7.05.34 PM.png

          • 2. Re: Shortcut problem with secondary key characters (Windows 10)
            LeRichie Level 1

            I forgot to tell that I have this problem between all Adobe CC apps on Windows (After Effects is even worst in this kind of problem).

             

            Using the same example as before; with this key, the primary character is comma and the secondary is semicolon. The comma is is already used as you can see in your screenshot for the grid.

             

            As an extra, I would like to still using the default shortcuts because is already in my reflexes and I would need to be changing again and again between Windows and Mac the shortcut profile everytime 'cause Adobe CC sync everything, including the shortcuts.

            This kind of problem started when I update to Windows 10 in my PC only.

             

            Thanks for your answer with screenshot.

            • 3. Re: Shortcut problem with secondary key characters (Windows 10)
              gener7 Adobe Community Professional & MVP

              That seems too involved. Try going to your CC Desktop app > Preferences and change the language to Spanish.

               

              When you go back to the main screen, Photoshop should then have an install button, which should drop the Spanish language pack into your PS program folder under Locales. The Spanish keyboard shortcut file should be there. Copy it into My Documents and use Edit > Keyboard Shortcuts to import the file in for your English version.

               

              Screen Shot 2018-04-08 at 8.36.42 PM.png