13 Replies Latest reply on Jun 7, 2018 2:12 PM by Chuck Braman

    Extremely slow-loading composition/video widgets

    Chuck Braman Level 1

      Over the past year, after trying to use every third-party video gallery widget available and encountering serious bugs or limitations that the developers were unable to address (or sometimes to acknowledge), I removed them all from my site and substituted a combination of the native version 1 Vimeo widget with the native Muse Composition widget to make my video galleries.

       

      Apart from being very finicky to set up, these widgets have been wonderfully bug-free, however, using them has radically increased the load time for the pages in my site (five of them) in which they are used.

       

      To give the most extreme example, try visiting this page: https://www.newyorkjazzbands.com/videos

       

      On my 100+ Mbps connection the page takes a full 22 seconds to load, as opposed to a few seconds when I used the third-party gallery widgets.

       

      So far as I can tell, the videos themselves don't begin to download unless they are clicked (i.e., played), and likewise, the poster frames (thumbnails) for the videos don't load until you select their specific trigger, so it is a little baffling to me as to what exactly is slowing down the pages so radically.

       

      Interestingly, as an experiment, I tried removing all but one of the videos in each composition widget (decreasing the video count by about 2/3rds), but this only decreased the page-load speed to 15 seconds.

       

      So I'm curious if anyone in the Muse team knows what is the cause of the extremely slow load time when using a combination of the video and composition widgets, and whether it's something that could be fixed if it is a bug.

       

      Any insight/advice from the team would be very much appreciated.

        • 1. Re: Extremely slow-loading composition/video widgets
          Preran Adobe Employee

          I am on a high speed connection as well and ti took around 9 seconds for the preloader to complete after which I was able to play the videos without any problem.

          • 2. Re: Extremely slow-loading composition/video widgets
            Chuck Braman Level 1

            I cleared my cache and visited today and it took 20 seconds, but that's really neither here nor there because 9 seconds is still a very long time for a web page to load. Of course once it loads the videos are able to be played, but that's a non sequitur.

             

            If you could take a moment to try and analyze the cause of the situation and address the particular questions I raised, that would be more helpful to me. I've pasted the relevant portion of my original post below.

             

            > So far as I can tell, the videos themselves don't begin to download

            > unless they are clicked (i.e., played), and likewise, the poster frames

            > (thumbnails) for the videos don't load until you select their specific

            > trigger, so it is a little baffling to me as to what exactly is slowing

            > down the pages so radically.

            >

            > Interestingly, as an experiment, I tried removing all but one of the

            > videos in each composition widget (decreasing the video count by about

            > 2/3rds), but this only decreased the page-load speed to 15 seconds.

            >

            > So I'm curious if anyone in the Muse team knows what is the cause of the

            > extremely slow load time when using a combination of the video and

            > composition widgets, and whether it's something that could be fixed if it

            > is a bug.

            >

            > Any insight/advice from the team would be very much appreciated.

            • 3. Re: Extremely slow-loading composition/video widgets
              ankushr40215001 Level 7

              Not at all bad on my end.

               

              Took less then 5 secs to load, and especially the user of preloader is very effective.


              So I don't see any further scope of improvements in your site with respect to speed.

               

               

              Regards,

              Ankush

              • 4. Re: Extremely slow-loading composition/video widgets
                Chuck Braman Level 1

                @Preran

                @ankushr40215001

                 

                I found it interesting that the page loads quickly for you, so I tested it on my neighbor's computer, a PC, and also on a Mac at a local Best Buy store. On both, sure enough, it loaded quickly, consistent with your experiences.

                 

                Now what is interesting is, as I mentioned earlier, my home connection is 100+ Mbps (and my MacBook is a top of the line 2016) and everything but those particular pages (with the composition widgets with Vimeo widgets inside) loads quickly. I also experience the same slowness when navigating to the page from the same laptop when used at a cafe I go to daily. There definitely seems to be some causal connection between the use of the combination compositon/vimeo widgets and the load speed on my laptops because in all other circumstances there are no speed issues with any other pages on my site or on other sites on my laptops.

                 

                Of course, if this issue was limited to me, I wouldn't care, but if I'm experiencing this, some other visitors, perhaps many other visitors, must also be experiencing the same issue when visiting my site.

                 

                A variable that may provide insight into the source of the problem is that on my MacBooks, after navigating to the page, there is about a 12-second pause starting with the screen of the previously loaded site, and then a completely blank screen, before the preloader appears. On the other computers (my neighbors and Best Buy, and apparently in your experience as well), the previously loaded site disappears and the preloader appears without any significant pause. So whatever is slowing down the page on my computer is something that is taking place before the preloader loads.

                 

                Here is a link to a screen recording I made today of the page loading on my Mac, so that you can see the behavior for yourself: http://bit.ly/2IZAYMc

                 

                (By the way, I checked with tech support with my web host, Siteground, and they confirmed that it is not an issue that is caused by their servers or any instructions in the .htaccess file.)

                • 5. Re: Extremely slow-loading composition/video widgets
                  ankushr40215001 Level 7

                  Probably we need to check this out in any other open networks because in our office network your site works super smooth.

                   

                  So I would like to assure you that with a moderate internet speed your site loads fine on both Mac and Windows.

                  Will test this more and update you with any findings.

                   

                   

                  Regards,

                  Ankush

                  1 person found this helpful
                  • 6. Re: Extremely slow-loading composition/video widgets
                    fotoroeder Adobe Community Professional

                    Same to me – works pretty fast.

                     

                    Best Regards,

                    Uwe

                    2 people found this helpful
                    • 8. Re: Extremely slow-loading composition/video widgets
                      gddmpro Level 1

                      Hi,

                       

                      I am just having the same problem with all my Muse websites on my mac just loading extremely slow, some of them don't even have any videos, like this one:

                      http://www.steuerberaterkanzlei-bielefeld.de/

                       

                      This is also happen when I try to preview the page in the browser it is taking over 30 sec.

                      When I try it on another computer it works fine.

                       

                      How can this be, is there anything I can do about it?

                       

                      Thank you

                      Peter

                      • 9. Re: Extremely slow-loading composition/video widgets
                        Chuck Braman Level 1

                        ankushr40215001

                         

                        > Probably we need to check this out in any other open networks because

                        > in our office network your site works super smooth.

                         

                        Have you had an opportunity to do this yet?

                         

                        > So I would like to assure you that with a moderate internet speed your

                        > site loads fine on both Mac and Windows. Will test this more and update

                        > you with any findings.

                         

                        On some, but not all machines—see my comments and gddmpro 's comments above.

                        • 10. Re: Extremely slow-loading composition/video widgets
                          ankushr40215001 Level 7

                          Hey there,

                           

                          I have found that in a 3g mobile connection, and a public network WiFi the  site works quite slower as reported.

                           

                          However, in an office network, secured network, and 4g connections the site works as expected.

                           

                           

                          Regards,

                          Ankush

                          • 11. Re: Extremely slow-loading composition/video widgets
                            Chuck Braman Level 1

                            Hi Ankush,

                             

                            I understand it will be slower on a slower connection.

                             

                            My issue—20+ second download—happens on a 2016 Macbook Pro with a 223 Mbps wifi download speed.

                             

                            Anyway, it looks like this won't be solved.

                             

                            Chuck

                            • 12. Re: Extremely slow-loading composition/video widgets
                              Chuck Braman Level 1

                              Ankush, you marked your own answer as correct but it's not. I indicated that the problem occurs on a 223 Mbps connection. Reporting back that the site will load more slowly over 3g does not address the issue, it's a non sequitur.

                              • 13. Re: Extremely slow-loading composition/video widgets
                                Chuck Braman Level 1

                                This has been labeled "assumed answered" when I indicated that it has not been answered, neither for me nor, I assume, for gddmpro