12 Replies Latest reply on Aug 27, 2008 6:08 AM by Michelle D.

    red script icons

    Michelle D.
      I recently upgraded from X5 to RoboHelp 7. I have an HTML project that I placed on a network drive (as a backup) to ensure I kept my projects "safe". Now that I am using the projects on the hard drive, one project in particular has two red script icon boxes at the top. I have hundreds of topic pages. Is there a way to delete these "extra" scripts from the entire project? or do I have to visit each topic page and delete them?
      Michelle
        • 1. Re: red script icons
          Captiv8r Adobe Community Professional & MVP
          Hi Michelle

          Your problem is probably deeper than you think. My guess is that you have managed to overlay your pristine project files with modified WebHelp output files.

          You have some cleanup ahead of you if you don't have a backup handy. The article below should assist with the cleanup.

          Click here to read the article

          Cheers and good luck with the cleanup... Rick
          • 2. Re: red script icons
            Michelle D. Level 1
            Okay, I'm really in deep chiemsee! My Robohelp software is loaded on C. My files there have the problems. I have a copy on the network drive for posting to our internet (our webmaster does that). The previous version that is currently posted works on the internet. However, if I try to open the index and table of contents from the RoboHelp application on that drive, I get nothing. (even though it works on the webpage). I have copies on my two hard drives, and one individual network. The one on the individual network seems to have everything I need - no extra red boxes, no scripts, TOC and index.
            How do I get that to my hard drive where the application is loaded, so that they become my working files, and I can make my updates. I followed your instructions on my "other" hard by removing the script code and the icons, but it looks like the TOC and index have disappeared from that version. I feel like I'm running in circles now! I just want ONE good project file.
            • 3. Re: red script icons
              Captiv8r Adobe Community Professional & MVP
              Hi Michelle

              From what you have written, it would seem you may want or need some experienced eyes looking at the setup.

              I'd be happy to contract with you for an hour or so to resolve the issue. If that sounds like an interesting possibility, send me a private message to rstone75 (at) kc (dot) rr (dot) com and I'll be happy to set up a screen sharing session where we converse in real time and are able to see each other's screens.

              Or if you would prefer using the forums, that's cool too. Just thought I'd toss out the possibility.

              Cheers... Rick
              • 4. Re: red script icons
                Michelle D. Level 1
                Unfortunately, I work for the Federal government, so I appreciate the offer, but can't make it happen. I'll have to muddle through the forum.

                Michelle
                • 5. Re: red script icons
                  Michelle D. Level 1
                  Question 1: Here's what I "hope" I can do. Delete all the folders, including the project folder, from C. (where RoboHelp app is loaded.) Can I cut and paste from the individual network directly back to C? Then open up the xpj file, change the path when I generate?

                  Question 2: I have no idea how I could overwrite the modified output files to the project files. How does that happen?
                  • 6. Re: red script icons
                    Captiv8r Adobe Community Professional & MVP
                    Heya Michelle

                    Did you balk because of the red tape involved or the technical aspects of allowing someone to see your desktop?

                    If you want, I'll be happy to spend 15 or 20 minutes or so at no charge to try and help you sort it. Totally up to you.

                    Cheers... Rick
                    • 7. Re: red script icons
                      Michelle D. Level 1
                      Rick,
                      Balking for several reasons: I cannot allow access to my computer (no authority, and it's a government no-no; I cannot obligate any funds for help; red tape? kinda....
                      Michelle
                      • 8. Re: red script icons
                        Captiv8r Adobe Community Professional & MVP
                        No problem

                        Okay, so how to try and help flying totally blind.

                        You wrote:
                        Okay, I'm really in deep chiemsee!

                        Sounds like it!

                        My Robohelp software is loaded on C.

                        As it should be.

                        My files there have the problems.

                        Files on C? You mean project files or RoboHelp application files? I'm guessing you mean project files.

                        I have a copy on the network drive for posting to our internet (our webmaster does that).

                        I'm guessing the "Copy on the network" is output files, right?

                        The previous version that is currently posted works on the internet. However, if I try to open the index and table of contents from the RoboHelp application on that drive, I get nothing. (even though it works on the webpage).

                        And that would be expected if you are looking at output files. This is because all the source project files aren't there. There are many files that control and track the project that don't end up in the output. So I'm not the least bit surprised this isn't working.

                        I have copies on my two hard drives, and one individual network.

                        Copies of what? Source files or output files?

                        The one on the individual network seems to have everything I need - no extra red boxes, no scripts, TOC and index.
                        How do I get that to my hard drive where the application is loaded, so that they become my working files, and I can make my updates.

                        Normally the process is as simple as opening Windows Explorer and copying the files from the Network to the local C drive. But until we are absolutely certain you are copying Project files and not Output files, it's anyone's guess.

                        I followed your instructions on my "other" hard by removing the script code and the icons, but it looks like the TOC and index have disappeared from that version. I feel like I'm running in circles now! I just want ONE good project file.

                        And getting that will take a bit of sleuthing and work. Unfortunately, with no true source files in the mix, you are left with trying to re-create the project. It's not unlike having the leaning tower of Pisa collapse, then being handed a photo of what once was and being expected to rebuild it.

                        Many have followed the steps I outlined originally and so far nobody has come back to say they are incomplete or failed to work. So you might try carefully re-tracing your steps. Maybe you missed a step along the way.

                        Wish I could be of more assistance here... Rick
                        • 9. Re: red script icons
                          Michelle D. Level 1
                          Thanks Rick,
                          I've given a few more answers below to your assumptions just to be clear. I'm going to forge ahead and hope it works. I'm still not absolutely sure how I got in this mess in the first place, but I think I have an idea what caused it. Anyway, thanks much for your help.

                          Files on C? You mean project files or RoboHelp application files? I'm guessing you mean project files.
                          ANSWER: All Files.

                          I have a copy on the network drive for posting to our internet (our webmaster does that).

                          I'm guessing the "Copy on the network" is output files, right?
                          ANSWER: again, all files, but I think the webmaster only uses the output files (that would be the WebHelp folder, right?)

                          The previous version that is currently posted works on the internet. However, if I try to open the index and table of contents from the RoboHelp application on that drive, I get nothing. (even though it works on the webpage).

                          And that would be expected if you are looking at output files. This is because all the source project files aren't there. There are many files that control and track the project that don't end up in the output. So I'm not the least bit surprised this isn't working.
                          ANSWER: If I go into the network drive and actually click on the project file (the .xpj file) I should be able to open the project and see the index and toc, right?

                          I have copies on my two hard drives, and one individual network.

                          Copies of what? Source files or output files?
                          ANSWER: The source files and the output files (I have an overall folder with the project name. Then, ALL the subfolders, files, the project file, etc. are there. I delete the old overall folder from the network drive, then paste in the updated folder from the hard drive.)

                          The one on the individual network seems to have everything I need - no extra red boxes, no scripts, TOC and index.
                          How do I get that to my hard drive where the application is loaded, so that they become my working files, and I can make my updates.

                          Normally the process is as simple as opening Windows Explorer and copying the files from the Network to the local C drive. But until we are absolutely certain you are copying Project files and not Output files, it's anyone's guess.

                          I followed your instructions on my "other" hard by removing the script code and the icons, but it looks like the TOC and index have disappeared from that version. I feel like I'm running in circles now! I just want ONE good project file.

                          And getting that will take a bit of sleuthing and work. Unfortunately, with no true source files in the mix, you are left with trying to re-create the project. It's not unlike having the leaning tower of Pisa collapse, then being handed a photo of what once was and being expected to rebuild it.

                          Many have followed the steps I outlined originally and so far nobody has come back to say they are incomplete or failed to work. So you might try carefully re-tracing your steps. Maybe you missed a step along the way.

                          Wish I could be of more assistance here... Rick
                          • 10. red script icons
                            MergeThis Level 4
                            Work on source files on C:\ only. Source file folders will contain:
                            =============================
                            MyProject.ali
                            MyProject.brs
                            etc.
                            rhakeyword.apj
                            rhbag.apj
                            etc.
                            All project topic files and grahics
                            Some .css, .ssl, etc.
                            =============================

                            Best practice is to generate your output any other place on C:\ than the RH default !SSL!\WebHelp folder. That way, doing a simple Copy/Backup of your source files doeasn't also include the output files.

                            After you've generated output [somehwere else] on the C:\ drive, you can publish that output (all, or only the changed files) to any number of locations on your machine or networked servers. That output, by the way, will not contain the aforementioned MyProject*.* and rh*.apj files, but will contain other project-specific files.


                            Good luck,
                            Leon

                            EDIT: Hey, I just noticed your reference to deleting the scripts in your source files (in your initial post). Why? My gues is, these are JavaScript extras that had been inserted for specific reasons (maybe some onMouseOver effects, adding the current date, etc.). I'd so some checking on this by actually clicking and hovering on the previous output, to see what's up.
                            • 11. Re: red script icons
                              Michelle D. Level 1
                              Thanks, Leon. I actually have done that (to my D drive) but I still get all the files (source, output, etc.) I think I have actually cleaned up my project - all 300+ pages! I have one issue remaining - two of the graphics don't appear in the output file after I generate. First I lost the associated pop ups to the screen image. Now the image doesn't show. But I'll get it fixed!
                              Thanks,
                              Michelle
                              • 12. Re: red script icons
                                Michelle D. Level 1
                                Thank you, Captiv8tor and Merge This for your help!