4 Replies Latest reply on Jan 7, 2009 1:09 PM by hammerkp

    SWF slide show does not play

    hammerkp
      I need some help with a Fireworks swf slide show.
      This is the web page: http://www.shortlifeweb.com/DrTedScott/index1.html
      And here is a hard link to the slide show: http://www.shortlifeweb.com/DrTedScott/images/slideshow.swf

      The slideshow.swf works fine, so I think the files and swf are properly located.

      However, in the index1.html, the slideshow does not play.

      Any help would be appreciated.

      Ken.
        • 1. Re: SWF slide show does not play
          sw2gtg
          Post your main code so we can make sure there are no errors that would prevent the movie from displaying.
          • 2. Re: SWF slide show does not play
            hammerkp Level 1
            Here is the code. Thanks so much for your help.

            <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="550" height="400" id="FlashID2" title="Slideshow2">
            <param name="movie" value="images/slideshow.swf" />
            <param name="quality" value="high" />
            <param name="wmode" value="opaque" />
            <param name="swfversion" value="8.0.35.0" />
            <!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you don’t want users to see the prompt. -->
            <param name="expressinstall" value="Scripts/expressInstall.swf" />
            <!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
            <!--[if !IE]>-->
            <object type="application/x-shockwave-flash" data="images/slideshow.swf" width="550" height="400">
            <!--<![endif]-->
            <param name="quality" value="high" />
            <param name="wmode" value="opaque" />
            <param name="swfversion" value="8.0.35.0" />
            <param name="expressinstall" value="Scripts/expressInstall.swf" />
            <!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
            <div>
            <h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
            <p><a href=" http://www.adobe.com/go/getflashplayer"><img src=" http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
            </div>
            <!--[if !IE]>-->
            </object>
            <!--<![endif]-->
            </object>
            • 3. Re: SWF slide show does not play
              Level 7
              The direct link to the slideshow doesn't work either. It could have
              something to do with it pointing to a file that might be on your hard drive:
              <script src="res://mshtml.dll/objectembed_neutral.js">

              Here's the source code for the page
              http://www.shortlifeweb.com/DrTedScott/images/slideshow.swf:

              <html><head><script
              src="res://mshtml.dll/objectembed_neutral.js"></script></head><body
              objectSource=" http://www.shortlifeweb.com/DrTedScott/images/slideshow.swf"
              onload="ObjectLoad();" leftmargin=0 topmargin=0 scroll=no> <form
              id="objectDestination"></form> </body></html>

              MD




              hammerkp wrote:
              > I need some help with a Fireworks swf slide show.
              > This is the web page:
              > http://www.shortlifeweb.com/DrTedScott/index1.html And here is a hard
              > link to the slide show:
              > http://www.shortlifeweb.com/DrTedScott/images/slideshow.swf
              >
              > The slideshow.swf works fine, so I think the files and swf are
              > properly located.
              >
              > However, in the index1.html, the slideshow does not play.
              >
              > Any help would be appreciated.
              >
              > Ken.


              • 4. Re: SWF slide show does not play
                hammerkp Level 1
                To make things simple, I created a blank page - no template, no formatting. And it still does not play.
                According to some of the tutorials I have seen, the slide show should play within Dreamweaver, but it doesn't play there either.

                Thanks.

                http://www.shortlifeweb.com/DrTedScott/slideshow_test.html

                I am including the entire html code.

                <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" " http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
                <html xmlns=" http://www.w3.org/1999/xhtml">
                <head>
                <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
                <title>Untitled Document</title>
                </head>

                <body>
                <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="550" height="400" id="FlashID" title="showing_photos">
                <param name="movie" value="images/slideshow.swf" />
                <param name="quality" value="high" />
                <param name="wmode" value="opaque" />
                <!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
                <!--[if !IE]>-->
                <object type="application/x-shockwave-flash" data="images/slideshow.swf" width="550" height="400">
                <!--<![endif]-->
                <param name="quality" value="high" />
                <param name="wmode" value="opaque" />
                <!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
                <div>
                <h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
                <p><a href=" http://www.adobe.com/go/getflashplayer"><img src=" http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
                </div>
                <!--[if !IE]>-->
                </object>
                <!--<![endif]-->
                </object>
                <script type="text/javascript">
                <!--
                swfobject.registerObject("FlashID");
                //-->
                </script>
                </body>
                </html>