8 Replies Latest reply on May 22, 2018 12:09 PM by jeromiec83223024

    FireFox is Disabling Shockwave Flash

    qsgt69541341 Level 1

      Firefox disables shockwave flash plugin option to "Never Active" and "Block dangerous and intrusive Flash content" option is selected while running scripts through selenium webdriver. Because of it, unable to click on Flash objects.

      I have tried below options but didn't work for me.

      1. Tried manually setting shockwave flash plugin( version 29.0) option to "Always Activate" and deselected "Block dangerous and intrusive Flash content" option.
      2. Used below code in configuration file.

         3. I tried changing all the possible combinations of

      • plugins.http_https_only
      • plugins.flashBlock.enabled,

      Still when my script is running, Shockwave Flash is set to "Never Activate" in Firefox quantum browser(Version:60.0) but same issue is not noticed in older versions of FireFox broswer(version:46).

       

       

      Please provide solution to set shockwave Flash plugin to "Always Activate".

       

       

       

      This post moved from Adobe Shockwave Player to Using Flash Player [Moderator]

       

       

       

       

      Title edited for brevity by moderator. Was:"While Automating Websites through Selenium, FireFox(Version:60) is Disabling Shockwave Flash ( version 29.0) player because of it  Flash Objects cannot be clicked while running scripts. Please provide us solution to always enable flash player ."