4 Replies Latest reply on Mar 17, 2008 7:08 PM by KevinDalvi

    Flex 3 Charts don't load data and lables only show [object Object]

    KevinDalvi
      I have a Flex 3 Chart that is receiving it's data from the .NET Web Service. The charts works fine when I test it from Flex Builder 3 but the chart does not display any colums or labels when accessed from the server e.g. http://localhost:2459/FlexChart/main.html

      The labels are not showing up properly. It just displays [object Object] instead of the actual label and there are no bars/columns in the chart. Also, I mapped the same datasource of the chart to a data grid to make sure it's receiving the data from the web service and I found out that it is receiving the data properly.

      Any ideas / thoughts will be appreciated. Thanks!
        • 1. Re: Flex 3 Charts don't load data and lables only show [object Object]
          ntsiii Level 3
          This sounds like two different issues.

          [object Object] displays when you attempt to display a complex object in a control that can only display text. Look at how you are feeding the labels.

          The "works under FB but not on the server" issue is almost always a security sandbox issue. You seem to have eliminated that, but check again.

          Tracy
          • 2. Re: Flex 3 Charts don't load data and lables only show [object Object]
            KevinDalvi Level 1
            Thanks for your reply. Since the chart works fine when I launch the main.html by double clicking on it, wouldn't it mean that the charting component does not have a problem with using the data received to display the labels, legend and chart? May be I'm missing something here. But the chart in the flex app works great locally.

            On the other hand, since it's not working on the server, I do agree with you that it could be a security problem. But how can everything in the flex app work file (as in it loads the drop down lists, other data elements, even the chart's legend) except the chart bars and graphs themselves. I even added a data grid to display the data for the chart. Even that loads fine.

            Can you think of any additional security checks that are required for the charting component?
            • 3. Re: Flex 3 Charts don't load data and lables only show [object Object]
              KevinDalvi Level 1
              Thanks for your reply. Since the chart works fine when I launch the main.html by double clicking on it, wouldn't it mean that the charting component does not have a problem with using the data received to display the labels, legend and chart? May be I'm missing something here. But the chart in the flex app works great locally.

              On the other hand, since it's not working on the server, I do agree with you that it could be a security problem. But how can everything in the flex app work file (as in it loads the drop down lists, other data elements, even the chart's legend) except the chart bars and graphs themselves. I even added a data grid to display the data for the chart. Even that loads fine.

              Can you think of any additional security checks that are required just for the charting component?
              • 4. Re: Flex 3 Charts don't load data and lables only show [object Object]
                KevinDalvi Level 1
                Alright, I figured it out. It was because of the security issue as well as something to do with the view stack not displaying in the same order when accessed from the server as it would locally.