0 Replies Latest reply on Mar 3, 2008 3:01 PM by noahbird

    500 error viewing http://localhost/flex2gateway

    noahbird Level 1
      I’m trying to setup Flex 3 to work with CF using Flash Remoting and I’m stuck getting the flex2gateway to work. I have CF 8 installed as a standalone server integrated with IIS. I'm getting a 500 error when I view http://localhost/flex2gateway in a browser. Here’s the error and various things I’ve tried. I’ve been all over the web and found a number of suggested resolutions but none of them work. Sites I’ve looked at include:

      http://www.drisgill.com/index.cfm/2006/3/22/Flex-2-Beta-2--flex2gateway-Problem
      http://www.forta.com/blog/index.cfm?mode=search


      Here's the error when I try to hit the gateway from my mxml page:

      ERROR: [RPC Fault faultString="Send failed" faultCode="Client.Error.MessageSend" faultDetail="Channel.Connect.Failed error NetConnection.Call.Failed: HTTP: Failed: url: ' http://localhost/flex2gateway/cfamfpolling'"

      I’m still totally stuck here (it’s been a solid 10+ hours). I’ve visited at least 20 sites that all have solutions that worked for them including:


      - Running C:\ColdFusion8\bin\connectors\Remove_ALL_connectors.bat followed by C:\ColdFusion8\bin\connectors\IIS_connector.bat

      - Editing services-config.xml and changing the value of the uri argument in the endpoint node for the channel-definition of ‘cf-polling-amf’. I’ve tried all sorts of things like removing {context.root} from the path, hard coding the path, etc. I've also set the port to 80. What’s strange to me is that no matter what I change the value too, even something fake like “FOOBAR”, the error always shows the same failed url (and I restart CF in between too)

      - Ensuring the "/" is at the end of my path (i.e. http://localhost/flex2gateway/")


      Any help would be so greatly apprieciated.

      Thanks in advance!