4 Replies Latest reply on Oct 9, 2018 3:28 AM by gsoul

    Dynamic link media server failed to launch

    Peakoverload Level 1

      It seems that in the past 4-5 months every single time I go to use Lightroom I find something has 'broken'. As a result I'm spending more time 'fixing' LR then using it for what I bought it for and it's getting very annoying.

       

      Anyway, rant over. Two weeks ago I was using LR and everything was working correctly, then last week I was on holiday and so my iMac was switched off and nobody has used it or LR until I launched it yesterday to download all my photos. All my photos imported into my catalog fine, it did fail to import the videos I'd shot which were .MOV files but LR never seems to be able to import them and I don't really need video in LR so it's never particularly bothered me.

       

      I was able to edit and organise the photos without problem but when I try to do a slideshow I then get the message "Dynamic link media server failed to launch" after which the play button is greyed out.

       

      I tried uninstalling and reinstalling LR. No difference

       

      I tried a solution I found on here where you open a Finder window and Go to Home, make sure you have read/write access, unlock it and then apply to all enclosed items. When I did this, relaunched LR and tried to play the slideshow i didn't get an error message but the screen would just go black for 20 seconds or so. After several times doing this I then got the same Dynamic Link media server error message.

       

      Tried repairing permissions on my system drive. No difference.

       

      I'm running OSX High Sierra 10.13.4 with LR Classic CC 7.3.1

        • 2. Re: Dynamic link media server failed to launch
          Peakoverload Level 1

          You, sir, are a STAR!!

           

          Thank you so much, I'd been going around and around in circles for hours trying to find the solution.

          • 3. Re: Dynamic link media server failed to launch
            Ian Lyons MVP & Adobe Community Professional

            Thanks for confirming that the procedure in linked post worked.

            • 4. Re: Dynamic link media server failed to launch
              gsoul

              Hi, hijacking this thread with the same issue but with no solution yet.

               

              I have a Mac Pro on which I've had my catalogue and all my original photos on the internal drive and been happy with it.

              Now I got a newer iMac and since the drive on it is too small I decided to move everything to my Synology NAS and keep my original files on the NAS and the Catalogue locally on the iMac.

               

              Now here's what happens (this is still all on the old Mac Pro).

              My Catalogue consists of approx 24 000 files. I made a complete copy of it and moved it to the NAS and then imported all files to LR again from the NAS so I can export my Catalogue and keep all tags and keywords.

              The import only showed about 15 000 files at first. I look right on the NAS and I can see all files are there, but LR just doesn't import them. I start to investigate and notice that mostly video files (.mov) are the ones missing giving me the "Dynamic link server failed" error.

              Although even jpeg and in some cases complete folders are missing. I sync specific folders again and then sometime it manages to sync a few, but not always. Then syncing again and again and a few files gets synced each time.

              I tried to add .old to the Dynamic folders in the link above with no luck. I even removed those folders but still same error. I noticed that the folders are not auto-created again once I removed them, don't know if that's ok?

               

              So, my problem is that Lightroom (on the same Mac Pro) can read everything from the local disc but not all from the NAS giving me the problem (as far as I know)  that I can not export my Lightroom catalogue to the iMac and keeping all keywords.

               

              Anyone with the same issue? Know of any solution or workaround? I don't want to spend another year tagging pictures again.....