7 Replies Latest reply on Mar 20, 2008 2:56 PM by Pet3689

    cannot properly edit Map Keys

    Pet3689 Level 1
      In RoboHelp 7 for HTML (but also v6), weI have problems with editing map keys for context-sensitive help.

      When we were using RoboHelp 6 for Word, editing map keys was easy.

      When we switched to RoboHelp for HTML (first v6 then v7), we could never figure out how to do this. We fully understand how map keys work, and we are computer-savvy. However, perhaps we are experiencing some kind of bug.

      For example, if we generate a new topic, we disabled automatic map key generation. Instead, we want to add our own map key number to this new topic. We select Topic Properties > Advanced > Edit Map Key to get to the map key editor. No matter what we try, we cannot add a new map key to the new topic. Similarly, changing the number of a map key is not possible. Basically, the task buttons at the bottom of the Edit Map Key screen are always disabled.

      We are currently editing the map key files directly, but that is not a solution of course.

      We read the Help documentation very carefully, but we simply cannot use these disabled task buttons, so that we are stuck.
        • 1. Re: cannot properly edit Map Keys
          RoboColum(n) Level 5
          Hi Pet3689 and welcome to the RH community.

          I can understand your frustration as I have often felt that that dialog should have been designed AFTER talking to Technical Authors. It is hideous.

          The crux of the problem is that the dialog displays "All Map Files" by default. When this is set, the "Assign" button is unavailable meaning you can't assign topics to your mapids. You get a default map file with each project but you can create your own. If you choose the default or your own map file from the drop down list, you'll get a list of the mapids that it contains. Click on one of them. You'll also get a list of topics in the project on the right. Click on the topic you want to assign to the mapid and click on the "Assign" button.

          Hope this makes things a bit clearer.
          • 2. Re: cannot properly edit Map Keys
            Pet3689 Level 1
            Thanks a lot, Colum.

            We figured that part out.

            However, how can we add new map keys to the existing files, or modify existing map keys in the existing files?

            Again, the buttons are disabled, always.

            We currently add new map keys or edit existing map keys directly in the map key files in Notepad.
            • 3. Re: cannot properly edit Map Keys
              RoboColum(n) Level 5
              You should have icons in the map file dialog to allow you to do this. Does this behaviour occur in any project or just one? Try opening one of the sample projects? The other things to check is that your project source files are located on a hard drive and not on a network.
              • 4. Re: cannot properly edit Map Keys
                AdamXT2
                It is really a terrible dialog, but this is what works for us:

                1. Make sure you have the <Project Map File> selected in the drop-down list.
                2. In the right-hand list, click on the Topic you want to assign an ID to.
                3. Under the Map IDs list there is a "Hide used IDs" checkbox, and then three buttons. The first button's icon does not make ANY sense to me whatsoever, but it means "add map ID."
                4. Click that cryptic-looking button. The Create/Edit Map ID dialog opens.
                5. Enter a name for the Topic ID (can be anything, just don't use any spaces) and the Map Number you want to assign, and click OK. The ID is assigned to the topic you selected earlier.

                To edit the assigned Map ID number or name, double-click on an ID in the Map IDs list. I don't know if you can actually change the assignment of one of these IDs -- the "Unassign" button always appears grayed out for me -- but you can delete a selected Map ID by selecting it and clicking the "X" button.

                Hope this helps!
                • 5. Re: cannot properly edit Map Keys
                  Level 2
                  This is probably irrelevant, but you write

                  "We are currently editing the map key files directly, but that is not a solution of course"

                  This is not obvious to me. I have been using NotePad (or WordPad because it is big) to configure our context help ever since we converted to HTML Help and find it to be fast, efficient, and error free.

                  As you hear people complain about the Edit Map IDs dialog in RoboHelp, keep in mind that it was designed for the situation in which the developer hands you a map file (.h or .hh). Since Microsoft's development tools lagged behind their push for HTML Help, many of us ended up working in a different environment, where this file is created by the help author. While RoboHelp allows you to do this, it has never been easy because HTML Help was designed to not have it done this way.

                  John
                  • 6. Re: cannot properly edit Map Keys
                    RoboColum(n) Level 5
                    Hi John.
                    As usual your posts are illuminating. You have converted me to your style of CSH map file editing. It is SO easy! I'll be passing that tip on to the others here. You will no doubt hear "whoops" of delight from the other side if the pond.
                    • 7. Re: cannot properly edit Map Keys
                      Pet3689 Level 1
                      Thank you so very much for your advice.

                      In the end, a combination of the posts in this topics, and some good luck helped us with this dialog.

                      We combined all of our map key files into a single one, and that somehow activiated some more options in the dialog.

                      We then followed your instructions, and learned from your advice. Now, we feel that we can handle this! We also hope that other will benefit from this topic.

                      Again, thank you very much!