5 Replies Latest reply on Jun 18, 2018 3:08 PM by Ale Hong

    penguin trouble

    Ale Hong Level 1

      Hi, I'm having trouble with my penguin puppet, I can't move the eyes or eyebrows, the rest is working great, can anyone please help Dropbox - pinguino.ai and this is the project Dropbox - pinguino.chproj

        • 1. Re: penguin trouble
          alank99101739 Level 4

          I will try to look later tonight, but my debugging process I documented at Debugging Adobe Character Animator Eyes – Extra Ordinary, the Series

           

          Its usually a stray pupil range tag.

          1 person found this helpful
          • 2. Re: penguin trouble
            alank99101739 Level 4

            Oh, it can save a lot of time if you can use the menu to "export puppet" which creates a ZIP file (with a .puppet extension). Its easier to transport between machines.

            1 person found this helpful
            • 3. Re: penguin trouble
              alank99101739 Level 4

              Just FYI, you exported the .chproj file - this file actually contains nothing (zero bytes long). So I imported the AI file. I think there are a few issues going on - I did a number of things (not sure they are all necessary) and got it going.

               

              • I deleted the right quarter and right profile. These are getting tagged, but they are hidden. You also don't have a "frontal" profile, nor a head turner. So I was worried CH was getting confused.
              • I think your artwork was created with groups rather than layers. I think most of the time CH needs layers. So I recreated sublayers for Head, Left Eye, Left Pupil etc and dragged the artwork from the groups into the layers.
              • I also create sublayers for Left Pupil, Left Eyeball etc. I don't know if I needed to, but I think CH creates children in the puppet hierarchy automatically when you just have a group, but it gives it the same name as the parent layer. When this is "Left Pupil" the child layer is given the same name, causing both layers to be tagged. I think this can cause problems.

               

              After doing all the the above, the eyes started moving. I don't know if they were all required. I may try a recording from scratch (I just tried some quick hacks to see what was going on). I can send the puppet back after that.

              1 person found this helpful
              • 4. Re: penguin trouble
                alank99101739 Level 4

                Ha! I tried to do a video this time. I started by deleting the unused profiles and it started working. So not uploading such a boring video after all ;-)

                 

                that is, the layers don't seem to be needed - groups worked fine.

                1 person found this helpful
                • 5. Re: penguin trouble
                  Ale Hong Level 1

                  thank you so much! You're a life saver!!! and your tutorial is super good too, very easy to follow and has lots of helpful tips