2 Replies Latest reply on Jun 18, 2018 10:44 AM by jenniferd53257281

    Cookies are not being set on my Launch implementation, how do I make this work?

    jenniferd53257281 Level 1

      I'm just starting to learn Adobe Launch (with the hopes that I can convert our tracking over to it). I've been (mostly) successful in setting up our tracking parameters however, my test site isn't setting any cookies (either from our VisitorAPI service, or from our custom plugins like s.getNewRepeat).

       

      I'm not sure what I need to do to get this to work.

       

      I know there's a section called cookies in the Analytics Extension, but I can't find anything on what the expected values are, if this is even the piece I'm missing.

       

      Thanks.

        • 1. Re: Cookies are not being set on my Launch implementation, how do I make this work?
          Jantzen.Belliston Adobe Employee

          Do you have the Experience Cloud ID Service extension installed and approved to your development environment? If so, can you see if an AMCV cookie is being set on your domain? You can check by using Google Chrome's developer console. It should look similar to the screenshot below.

           

          Banners_and_Alerts_and_Experience_League_Intelligent_Guidance___Adobe.png

          • 2. Re: Cookies are not being set on my Launch implementation, how do I make this work?
            jenniferd53257281 Level 1

            Hi Jantzen,

             

            Yes, I always had the Experience Cloud ID Service installed a approved to my development environment. However, I wasn't getting any cookies at all (I use the dev console all the time for testing, and I've been using it to compare our live sites to this demo).

             

            I did a little more work after posting this and started populating some of the fields based on some of the examples here:

            Marketing Cloud Help

             

            I know the link was for DTM, but I thought it may help.  However, there's no checkbox for request automatically.... Is this something we always need to fully setup? The old manual process just sort of did this automatically, which was a lot easier

             

            I filled in the following settings (I blocked out our specific cloud id and tracking server) and I'm now at least getting AMCV and AMCVS cookies (although, they seem to be against the subdomain rather than the domain as in our normal implementation (the hostname is a standard data element using Page Info: HostName, I can probably deal with this by using different code to get this value). If this needs to be populated, it must be variable since we will have 33 sites sharing the profile (I'd rather make one update than 33 once this is live).

             

            visitorexperience-setup.png

             

            Not sure if there are other items that I need to configure...

             

             

            However, I still seem to be missing all the other Analytics cookies we have on our live sites. Including cookies that should be set by our plugins (like s.getNewRepeat). Cookies such as gpv_pn, s_cc, s_nr are some of the cookies I recognize as being missing.

             

            Thanks for your help, I really appreciate it.