1 Reply Latest reply on Mar 29, 2008 11:59 AM by Vito A

    Flex3 and CF8

      I am a Flex newbie, experience ColdFusion user.

      I am using the trial version of Flex Builder 3 to create a new project (File/New/Project/FlexBuilder/Flex Project).
      In the New Flex Project window, I enter the project name, select "web application" as the application type, and select "ColdFusion" as the server technology. The "Use remote object access service" is checked, and "LiveCycle Data Services" is selected.

      In the next screen - in the server location, I enter "Standalone" as the installation type, the webroot is "c:\inetpub\wwwroot," and the root url is "" (I'm using IIS, so I'm not using port 8500). This is the screen where I see error at the top - "LiveCycle Data Services is not installed at the specified location." But I made sure LiveCycle Data Services was installed when I installed ColdFusion8, and "Enable Remote Adobe LiveCycle Data Management access" is checked in the ColdFusion Administator panel.

      Also, I went back in the New Project dialog and changed the server option to "ColdFusion Flash Remoting", and I was able to create a new project. However, now I cannot connect to my datasources using RDS configuration - I keep getting the error "Unable to connect to localhost".

      What is missing? Any help on either of these topics would be appreciated. If I can get this to work, it would justify the purchase of the full version.
        • 1. Re: Flex3 and CF8
          Vito A
          I assume from your post that you installed ColdFusion 8 onto your local machine because you're using as your root URL. During the installation you have to select to install RDS (which isn't checked by default) AND LiveCycle Data Services; LCDS prompts for a serial number, but defaults to a "free" single-CPU license after 120 days.

          I had to completely uninstall Coldfusion 8, and reinstall (twice) to make sure EVERYTHING was checked/selected for Flex 3 to be happy. Try removing the "localhost" default entry for RDS and creating your own with the IP address of your PC. Since you're running IIS (locally, right?) then RDS should be looking on port 80, and I think the RDS entry for "localhost defaults to using port 8500. Once you give it your PC's IP and the password for RDS that you create when you installed CF8, you should be able to do a successful test to ensure that RDS is even listening. When you selected to install to IIS (rather than install CF8's own web services) did you also specify "All Websites"?