5 Replies Latest reply on Jun 19, 2018 7:27 AM by kmtarochione

    Facebook Cover Video not working on iPads/iPhones

    jimbo_hippo Level 2

      Hi all,
      Firstly, I appreciate this is more of a Facebook question that a Premiere one but I want to ask this in a forum where people are experienced filmmakers rather than put it on a Facebook forum and become an idiot magnet!

       

      Yesterday I created 2 x Facebook cover videos for two different clients. I'm pretty experienced at encoding for social media and am generally happy with my output. However, despite my best efforts, I simply can't get a cover video to run on iPads without weirdery going on. Works fine on any desktop.

       

      So it's a 1min piece and an 89 second piece respectively shot in a mixture of 4K and HD on a Panasonic GH4 and Phantom 4 Drone. All clips are 25 or 50fps and each clients footage is unique to them shot by me so it's not a source media thing. I've also used these clips before with no issues on their pages. Initially I put the piece together then output to 820 x 462 H264 through media encoder as per the guidelines on FB. Uploaded to page and ran fine on my MacBook Pro in Safari but looked soft so I doubled the output res to 1640 x 924 and let FB crush it down to it's preferred res. Worked fine too on laptop.

       

      However when I viewed on an iPhone in the facebook app (tried several) the thumbnail image was there and a play button icon but it won't play. On my 2 iPads, the area where the video is is just a black square, not even a thumbnail. But heres the odd thing, below, on the timeline for both client pages, there's a timeline notification that 'client x has uploaded a new Cover Video' and it's playing away just fine there.

       

      I've since rendered out versions by setting my sequence settings to the recommended size, rendered out at varying sizes with the same results each time. I've revisited the guidelines on numerous occasions and I can't see why these clips just refuse to play. I've even rendered it out using my HD for YouTube preset which I've been using daily for 2 years and that doesn't work either on iPad or iPhone with the same above results.

       

      I've also tried uploading them to the page as videos as I normally do  (in various aspect ratios and sizes) and then selecting them from there. Same results.

       

      Anyone else experienced this?

       

       

      Devices used to test:

       

      MacBook Pro 2016 Touch Bar and Safari - works fine

       

      iPhone 6s+ x 2, iPhone 4s: thumbnail shows and play icon but icon does not play and no autoplay

       

      iPad Air 2: just black rectangle - no play icon at all - gives option to upload photo to replace but not video.