0 Replies Latest reply on Jul 1, 2018 9:47 AM by garzol

    Bug when text edit box and multiline text edit box are used together

    garzol Level 1

      Hi,

       

      I develop a plug-in for InDesign CC 2017 and 2018 and I am having an issue with the user interface. The problem is on both macOS and Windows and happens with both versions of InDesign.

       

      I created a palette which contains among other things a text edit box (in the resource file : TextEditBoxWidget) and a multiline text edit box (MultilineTextEditBoxWidget). The palette looks fine at first (see image 1) but if I switch the focus from the single line to the multiline : the text inside the single line box disappears and when I focus back on it (see image 2) I become unable to edit anything and I get stuck in this glitchy state until I give the focus to another object of the palette (not the multiline box but another box for example or a checkbox button or etc).

                    Sans titre-1.png

       

      I've tried everything to solve the problem : I changed the boxes to every possible ODFR type, I switched everything in the .fr file to EVE and I even tried to subclass different types of event handler but nothing works as the problem seems to stem from a lower level event handler file...

       

      btw if it helps I use Xcode 9.4.1 on macOS High Sierra Version 10.13.5