5 Replies Latest reply on Mar 20, 2008 3:58 PM by gresh

    How to avoid that IE warning about active content?

    dcmaxarts
      Hi people!

      Actually, I'm studying the Director and I'm so exciting with its possibilities! But each time when I test a published project in html and dcr for web purposes in IE, it returns a warning message about active content: "To help protect your security, Internet Explorer has restricted this file from showing active content that could access your computer"

      I want to learn how to avoid that message, once it can scare my website's visitors worried about bad intentioned web content. It can represent a big interactivity's loss!

      Searching for the forum's site, I already have seen the kelker's topic: " http://www.adobe.com/cfusion/webforums/forum/messageview.cfm?forumid=11&catid=186&threadid =1180809&highlight_key=y&keyword1=active", but does not worked to me. May I'm doing something wrong, once it's suposed to work, or with dcr it's really not so simple like that?

      Which is the secret anyway? Anyone knows?

      (Obs.: I would like to say sorry for any event of a possible gramatical error or strange string, once english is not my native language!)

      Thanks in advance! Awaiting for aswers!
        • 1. Re: How to avoid that IE warning about active content?
          Level 7
          Hi dcmaxarts,

          A bit of background to the issue. Microsoft was sued by someone who claimed they
          infringed on their patent of how plugins display through a browser and won.
          Microsoft changed the way Internet Explorer works with plugins like Shockwave,
          Flash, Quicktime etc. requiring the click to activate. But, you can get around it by
          using a Javascript call to the shockwave movie. Info on this is available at:
          http://www.adobe.com/designcenter/popular_topics/click_to_activate/
          http://www.adobe.com/devnet/activecontent/
          Here's the page which gives you the JS files and setup info:
          http://www.adobe.com/devnet/activecontent/articles/devletter.html

          If you have the latest Dreamweaver, or even the last version with the update, simply
          opening an html with the old shockwave tags in Dreaweaver will give you the option
          to convert it to the new JS system.

          By the way, microsoft has made a licensing agreement recently so that the older
          embed tags won't give the click to activate. Not sure when that will occur. It may
          be in the next IE update.

          Hope that helps.

          regards
          Dean

          Director Lecturer / Consultant / Director Enthusiast
          http://www.deansdirectortutorials.com/
          http://www.multimediacreative.com.au
          email: d.utian@unsw.edu.au

          • 2. Re: How to avoid that IE warning about active content?
            dcmaxarts Level 1
            Thanks for answering!!! Your post is very elucidative!

            I had not enough time to check all of your links posted above. But what I can tell you in advance is that I already had tryied your hint about Dreamweaver. I have de Dreamweaver CS3 (the laste version, I suppose). And everything works like you said, except that it worked exactly the same as before. Dreamweaver created a folder called scripts, and inside was the js file. In the html I also could verify the modifications, including the tag that calls the js file. I also have compared the html from Directors, with one modified from Dreamweaver and even with one created by the Flash that works properly, without that warning message. So I've inspected each distribuition's tags scheme to notice what could be wrong in that ones origined from Director. Not much I could do.

            What can be wrong? May I try anothers preference's sets in the convertion?

            But anyway, maybe tomorrow (or even today), I'll check your links to see if I find a solution for my problem. Independently from result, I'll give a feedback. (But sure, I'm still curious in what to do for this so simple Dreamweaver's solution works).

            Thanks again! Later I'll be back!
            • 3. Re: How to avoid that IE warning about active content?
              Level 7
              Hi dcmaxarts,

              I did not follow everything in your last post. Are you saying that Dreamweaver
              modified teh html by converting it to teh JS format, but even with that chance you
              experience teh click to activate? Is this being tested on a website or locally? I
              have converted html pages with Dreameweaver and they work perfectly OK without the
              click to activate.

              regards
              Dean

              Director Lecturer / Consultant / Director Enthusiast
              http://www.deansdirectortutorials.com/
              http://www.multimediacreative.com.au
              email: d.utian@unsw.edu.au

              • 4. Re: How to avoid that IE warning about active content?
                dcmaxarts Level 1
                Seeing your links I finaly got what solution it have. But it's not for my problem, initialy. It was another one.

                But for my sweet surprise, testing my html in the web host, my main problem disapear! But it's strange that testing my html in my local folder the problem persist!

                But notice, you have pointed a solution for when IE shows the active content, but it's not active and it's is just needed to tap a click on de area of content. My problem was another and was more serious, happening before the "tap problem". When I test my site in my local folder, the IE shows that blank space instead of my Director's content (like when the IE cannot load an image) and plus a yellow pastel band appears in top of my IE with the warning:"To help protect your security, Internet Explorer has restricted this file from showing active content that could access your computer" To show my content I have to click on the pastel yellow band, so a litle menu appears. There's have three options. I have to click on the first one, that is to unblock the content. Even, after appears an alert window in the middle of the screen warning again about the risk of allowing an active content. Just only confirming again to run is that I face the tap problem issue. Uhff!

                Maybe is a problem of my version of my Director? I thought it might be a commom problem, once it happens on every project that I finish. But if in the web hosts my project works well, so it doesn't care so much. But indeed is strange! What can be happening?

                Thanks so much for attention!!!! Now I feel easy to continue my studies without worring about any loss of interactivity!!!



                • 5. Re: How to avoid that IE warning about active content?
                  gresh
                  I presume you are using Internet Explorer offline, in which case you will have to alter IE's security settings to allow active content to be shown without the popup.

                  Inside IE, Go to Tools >> Internet Options >> Advanced.
                  Scroll done to the security section.
                  check "Allow active content to run in files on my computer"
                  that will stop the yellow popup you are talking about.

                  Paul