1 Reply Latest reply on Jun 27, 2018 1:35 AM by Adobe assassin

    Adobe Launch with Drupal 8

    Adobe assassin Level 1

      Hi One and all,

      Has anyone out there used launch with Drupal8?  I have a very simple test JSON defined data layer, which looks like the below

      <script>var digitalData =

      [

      {"page":

      {"pageInfo":{

      "pageName":"Home",

      "destinationURL":"\/home",

      "breadcrumb":"\/home",

      "pageCategory":"page"},

      "channel":

      {"primaryChannel":"home",

      "pageType":"page"},

      "attributes":

      {"language":null,

      "contentType":"page"}}}];</script>

       

      we would use JS, except Drupal8 doesn't like you out putting native JS to the page, so my developers advised to use JSON.  The issue I have is when I use _satellite.getVar('page Name'); I get a result of (" "), as far as I can tell all the config is correct inside the Launch UI, I have created a data Element with the name of page Name, the path to the data element is digitalData[0].page.pageinfo.pageName (Which I believe is correct).

       

      When I inspect the DataLayer with Data slayer, all the elements are visible and populated.  I am trying to understand why the data layer elements are empty when I use the  _satellite command.  I hope this is enough info.

       

      many thanks in advance.

        • 1. Re: Adobe Launch with Drupal 8
          Adobe assassin Level 1

          Hi All,

           

          Adobe Client care have solved this issue.  The resolution to edit/create the  data element and use the core extension, then element type should be Custom code as below

           

          ElementType.jpg

          once the editor opened I added the following code

           

          EditCode.jpg

          the above code works for thew JSON dataLayer in Drupal 8

          1 person found this helpful