4 Replies Latest reply on Mar 19, 2008 9:37 PM by Anand_Wipro

    Unable to access a Remote Object

    Anand_Wipro
      Hello Everyone,
      As mentioned in the subject, i'm unable to hit my Remote Object from the Flex UI. The Remote Object is available in a Web project having been properly configured in the remoting-config.xml , deployed in an EAR and run on Websphere Application Server. Inspite of the Remote Object being available, i get the following error. Any suggestions from you is welcome.


      [ERROR] [Message.General] Exception when invoking service: remoting-service
      with message: Flex Message (flex.messaging.messages.RemotingMessage)
      operation = isUserEntitledApps
      clientId = D9D6D48E-1A08-B6B0-3667-C13971ABC986
      destination = changeClientServiceImpl
      messageId = D195446B-CC94-C8A6-918A-83D30A88EAB8
      timestamp = 1204802504890
      timeToLive = 1204802504890
      body = null
      hdr(DSId) = D9D42196-E50F-3CE0-4C23-8248C64C6FC9
      hdr(DSEndpoint) = my-secure-amf
      exception: flex.messaging.MessageException: Cannot create class of type 'com.ssc.myss.globalnav.changeclient.ro.ChangeClientRO'. Type 'com.ssc.myss.globalnav.changeclient.ro.ChangeClientRO' not found.





        • 1. Re: Unable to access a Remote Object
          riesvantwisk Level 1
          it looks like that the backend cannot find your class. Did you put the generated jar file in your lib directory??
          Also, check your remoting-config.xml file if you did setup your destination properly, specially your source. And check if your services-config.xml file has a include for remoting-config.xml.

          I made a blaze-ds (blaze-ds with remoting and messeging with ant as the build tool) example which can be downloaded here: http://www.vantwisk.nl/riesvantwisk/entry/adobe_flex_and_blaze_ds

          Ries
          • 2. Re: Unable to access a Remote Object
            Anand_Wipro Level 1
            Hi riesvantwisk ,

            Many thanks for your response. But just to confirm, i have my remoting-config.xml and services-config.xml properly configured with the channel definition and destination information correctly. Just to update you that i have few other Remote Object calls that are been made to this remoting-config.xml and they work perfectly fine. The only important difference between these two RO calls is that for the successful RO call, the required Remote Object class is available as part of a JAR file in my EAR. But in case of the Unsuccessful RO call, the required Remote Object class is actually available in the WAR itself as part of WAR/WebContent/WEB-INF/classes.

            All other configuration information apart from this difference are literally the same for both the Remote Object calls.

            Once again many thanks for your response.
            • 3. Re: Unable to access a Remote Object
              riesvantwisk Level 1
              I had the exact same problem. I solved it to change my application from a ear deployment to a war deployment. This was when I was using JBoss.

              The people on the JBoss channel tried to explain me but you need to make profisions to make the jar available 'at some point'

              Unfortunately I am not extremely knowledgable in that area and I cannot really help you to solve using a ear deployment, just that I know about the problem and it has something todo how ear deployments work.

              So for me it was simple and I changed it to .war :)

              ries


              • 4. Re: Unable to access a Remote Object
                Anand_Wipro Level 1
                Many thanks for your response. But unfortunately i have to deploy into an EAR and then run the application. Let me see if i can solve it in some other means.

                Thanks again.