6 Replies Latest reply on Jul 9, 2018 6:59 AM by Adrian_Ilchuk

    Arms don't move during walk

    Adrian_Ilchuk

      My puppets arms will not move when he is walking.  I have each arm independent and I've made sure the Attach To is set to Auto and I've tried both the Weld and Hinge Attach Styles. I can move them by dragging them but they just won't move when walking. I've also tried the Arm Swing, Arm Angle and Elbow Bend settings and still nothing. I'm out of ideas.

        • 1. Re: Arms don't move during walk
          alank99101739 Level 4

          I would suggest checking the tags on the arms. You have to tag the elbows, wrists etc on the left and right arm. If you have done all of that, you could include some screen shots here showing the puppet hierarchy (and maybe the arm layer showing the tags).

          • 2. Re: Arms don't move during walk
            Adrian_Ilchuk Level 1

            Here is my hierarchy. Any help would be greatly appreciated. cody.jpgcody-hierarchy.jpg

            • 3. Re: Arms don't move during walk
              alank99101739 Level 4

              Thank you. Can you click on one of the arms to select it in the hierarchy, then show the handles on the artwork plus “tags” in the puppet properties. Your puppet hierarchy shows a “4” on the arm, so there are some handles there, but I cannot see what tags etc they are. The walk behavior looks for tags (in the puppet properties) for elbow and wrist and then “drags” those tagged handles for you automatically. If the tags are not correct, CH won’t know how to move the arm (just like the legs)

               

              Also in the screenshot you got, over in the puppet properties on the right, if you look at the bottom there is a “Handles” you can expand that list. That would also show which handles have been linked up vs not linked up. Anything with 0 means CH has not find the tag it needed. 1 means it found one tag etc. So if there are zeros for the arms that is another hint the tags are not right.

              • 5. Re: Arms don't move during walk
                alank99101739 Level 4

                Perfect. Sorry, I am not an expert on walk behavior, but at a guess its because you don’t have the Neck tag. Maybe the arms are moved relative to the neck, so if it fails to find the neck it cannot move the arms. I notice you don’t have hips or waist hooked up either.

                 

                The other one I don’t understand is when you clicked on the arm, it shows handles but I was expecting to see highlighted dots for tags in the puppet outline. If you click on the “A” above the tags, it shows the tags as text (I find that easier to read myself).  However since the “Handles” drop down shows it linked up that might be okay. I am just wondering if something funny is going on there...

                 

                If adding the neck does not work, you could try adding the tags on the nested “arm” layer instead of the parent “Right Arm” layer, but I doubt this is the problem. I strong guess is because you don’t have the neck tag representing the shoulders the arms are attached to.

                1 person found this helpful
                • 6. Re: Arms don't move during walk
                  Adrian_Ilchuk Level 1

                  Thanks for the tips. It turns out it wasn't the neck that was the issue but I need to add the hip and waist. Once I added those than the arms started working. Thank you so much for your help. If it wasn't for you I wouldn't have figured that out.