4 Replies Latest reply on Jul 3, 2018 10:54 AM by kriscave

    Unexpected error opening catalog.

    kriscave Level 1

      Unexpected error opening catalog.

      The catalog could not be opened due to an unexpected error.

      Started running into this dialogue when opening catalogs other than my current one. A few details on my system/organization before I get into the other stuff.

       

      Background Info:

      macOS High Sierra 10.13.5

      2015 Macbook Pro

      I organize my catalogs by year, generally 1 catalog per year.

      Until last week, I kept all of my catalogs on my laptop and had a program back them up to 2 external drives roughly every other night.

       

       

      Last week, I did my annual system wipe, and realized I only need my current 2018 catalog with me at all times. So after I reinstalled macOS, I only brought back my 2018 catalog. I suspect this is somehow related, but I haven't opened my 2017 catalog (or others) in a few months, so I can't verify. My Home folder and User Name is the same as before.

       

      Tonight I tried opening my 2017 catalog for website stuff and ran into this dialogue. This also happens for any catalog that isn't my current one on both the main drive and backup. I went through the forums and didn't find any solid answer, but did find one locked thread where a staff member was PM-ing a handful of users with the issues and apparently helping/fixing privately—no one ever disclosed the solution, or even the problem, in that thread, which is frustrating.

       

       

      Solutions I've Tried:

      – Restarting computer

      – Repair disk permissions on Macbook and external drives

      – Changing Get Info > Sharing & Permissions for all users on Macbook and external drives

      – Trash LR CC Preferences

      – Importing old catalogs into a brand new catalog (I get error "Lightroom cannot import from this catalog. The catalog does not appear to be a valid Lightroom catalog.")

      – Copying old catalogs to Desktop, then opening

      – Copying old catalogs to their original location on my Macbook

      – Rolling back Lightroom Classic CC to version 7.3, 7.2, and 7.1

      – Deleting the .lock file (most of these catalogs do not have one)

       

      – This one is strange: I tried repairing the catalog with LR and received the error:

      Temporarily Unable to Repair Corrupt Catalg

      Lightroom encountered problems reading or writing from disk when attempting to repair "2017-cc"

      My external drives have 2+ TB free and my Macbook has 300+ GB free. I tried both, and have permissions set to Read & Write for everyone.

       

      Odd Note:

      The backup catalogs that LR makes about once a week seem to open fine. However, this is still concerning to me as this happened to ALL of my old catalogs and I don't know why so I can prevent it from happening again.

       

      Has anyone found a solution to this or know what caused it? I find it peculiar/terrifying that my backed up catalogs on external drives won't open—kind of defeats the purpose of having redundancies.