2 Replies Latest reply on Jul 12, 2018 1:56 AM by axo315

    Viewing Unsigned Extensions in InDesign 2018 (13.1) does not work in Windows 10 (version 1803)

    axo315 Level 1

      Hi there,

      Has anybody else been having issues with viewing unsigned extensions in the latest build of Windows 10 which is version 1803?

       

      Before I updated Windows I was running version 1709 and unsigned extensions were working perfectly. I have the correct registry key in place at HKEY_CURRENT_USER\Software\Adobe\CSXS.8. If I was to remove this then I would still get my unsigned extensions appearing in the Extensions menu but it would just load a blank panel.

       

      Now in version 1803, with the same reg key in place, nothing appears in the Window -> Extensions menu at all. I've even added keys for all past CSXS versions and that didn't work. My manifest.xml file also has <Host Name="IDSN" Version="[11.0,13.9]"/> which means InDesign 13.1 should be covered.

       

      If I do sign the extension then it appears as normal. Obviously for development purposes I don't want to have to do this. I'm not sure if any other CC apps have this issue as I only develop for InDesign.

       

      This sounds like something Microsoft have changed within Windows, but wondering if there will be a fix on the CEP side or if there are any workarounds.

       

      Many Thanks!

        • 1. Re: Viewing Unsigned Extensions in InDesign 2018 (13.1) does not work in Windows 10 (version 1803)
          Trevorׅ Adobe Community Professional

          Sounds like the debug mode is not set correctly

          Try Setting Cep Debug Mode and Log Level the Easy Way | Creative-Scripts.com

          And if that doesn't work then try CSTK In Adobe App Console and Development Tool | Creative-Scripts.com

          The latter method will show you if the debug mode is set correctly but see the instructions there. You need to restart the app for the debug to take effect on the app.

          • 2. Re: Viewing Unsigned Extensions in InDesign 2018 (13.1) does not work in Windows 10 (version 1803)
            axo315 Level 1

            Thanks for your response Trevor. I tried both solutions you suggested, but my unsigned extension still doesn't appear in InDesign. As a test, I manually removed all registry entries for CSXS and re-added them all via your CSTK panel and unfortunately this still didn't work.

             

            I did try some of the Adobe CEP samples, as they're unsigned, to see if they work and they actually do! So that leads me to believe there's something in my manifest.xml file that's not right. I've pasted it below to see if you can see anything that looks off. Is there anything else, other than the reg entries and manifest that can cause an extension not to show up in the Extensions menu?

             

            <?xml version="1.0" encoding="UTF-8" standalone="no"?>
            <ExtensionManifest ExtensionBundleId="com.axomic.openassetforindesign.extension" ExtensionBundleVersion="2.4.0" Version="5.0">
              <ExtensionList>
                <Extension Id="com.axomic.openassetforindesign.extension" Version="2.4.0"/>
                <Extension Id="com.axomic.openassetloginwindow.extension" Version="1.0.1"/>
                <Extension Id="com.axomic.openassetdownloader.extension" Version="1.0.1"/>
                <Extension Id="com.axomic.openassetrelinkingwindow.extension" Version="1.0.0"/>
              </ExtensionList>
              <ExecutionEnvironment>
                <HostList>
                  <Host Name="IDSN" Version="[11.0,13.9]"/>
                </HostList>
                <LocaleList>
                  <Locale Code="All"/>
                </LocaleList>
                <RequiredRuntimeList>
                  <RequiredRuntime Name="CSXS" Version="5.0"/>
                </RequiredRuntimeList>
              </ExecutionEnvironment>
              <DispatchInfoList>
                <Extension Id="com.axomic.openassetforindesign.extension">
                  <DispatchInfo>
                    <Lifecycle>
                        <AutoVisible>true</AutoVisible>
                        <StartOn>
                            <Event>applicationActivate</Event>
                        </StartOn>
                    </Lifecycle>
                    <Resources>
                      <CEFCommandLine>
                        <Parameter>--enable-nodejs</Parameter>
                        <Parameter>--proxy-auto-detect</Parameter>
                      </CEFCommandLine>
                      <MainPath>./index.html</MainPath>
                      <ScriptPath>./main.jsx</ScriptPath>
                    </Resources>
                    <UI>
                      <Type>Panel</Type>
                      <Menu>OpenAsset</Menu>
                      <Geometry>
                           <Size>
                                <Height>800</Height>
                                <Width>300</Width>
                           </Size>
                           <MaxSize>
                               <Height>800</Height>
                               <Width>300</Width>
                           </MaxSize>
                           <MinSize>
                               <Height>400</Height>
                               <Width>200</Width>
                           </MinSize>
                      </Geometry>
                      <Icons>
                        <Icon Type="Normal">./OpenAsset_Logo_Square_64x64.png</Icon>
                        <Icon Type="RollOver">./OpenAsset_Logo_Square_64x64.png</Icon>
                        <Icon Type="DarkNormal">./OpenAsset_Logo_Square_64x64.png</Icon>
                        <Icon Type="DarkRollOver">./OpenAsset_Logo_Square_64x64.png</Icon>
                      </Icons>
                    </UI>
                  </DispatchInfo>
                  <CEFCommandLine>
                    <Parameter>--proxy-auto-detect</Parameter>
                  </CEFCommandLine>
                </Extension>
                <Extension Id="com.axomic.openassetdownloader.extension">
                    <DispatchInfo >
                        <Resources>
                            <MainPath>./downloader.html</MainPath>
                            <ScriptPath>./downloader.jsx</ScriptPath>
                            <CEFCommandLine>
                                <Parameter>--enable-nodejs</Parameter>
                            </CEFCommandLine>
                        </Resources>
                        <Lifecycle>
                            <AutoVisible>false</AutoVisible>
                        </Lifecycle>
                        <UI>
                            <Type>Custom</Type>
                            <Menu></Menu>
                        </UI>
                    </DispatchInfo>
                </Extension>
              <Extension Id="com.axomic.openassetloginwindow.extension">
                  <DispatchInfo >
                      <Resources>
                          <MainPath>./login.html</MainPath>
                          <ScriptPath>./login.jsx</ScriptPath>
                          <CEFCommandLine>
                              <Parameter>--enable-nodejs</Parameter>
                          </CEFCommandLine>
                      </Resources>
                      <Lifecycle>
                          <AutoVisible>true</AutoVisible>
                      </Lifecycle>
                      <UI>
                          <Type>ModalDialog</Type>
                          <Menu></Menu>
                          <Geometry>
                              <Size>
                                  <Height>600</Height>
                                  <Width>800</Width>
                              </Size>
                          </Geometry>
                      </UI>
              </DispatchInfo>
              </Extension>
              <Extension Id="com.axomic.openassetrelinkingwindow.extension">
              <DispatchInfo >
              <Resources>
              <MainPath>./relinking.html</MainPath>
              <ScriptPath>./relinking.jsx</ScriptPath>
                <CEFCommandLine>
                    <Parameter>--enable-nodejs</Parameter>
                </CEFCommandLine>
              </Resources>
              <Lifecycle>
                  <AutoVisible>true</AutoVisible>
              </Lifecycle>
              <UI>
                  <Type>ModalDialog</Type>
                  <Menu></Menu>
                  <Geometry>
                      <MaxSize>
                          <Height>1600</Height>
                          <Width>1800</Width>
                      </MaxSize>
                      <MinSize>
                          <Height>600</Height>
                          <Width>800</Width>
                      </MinSize>
                      <Size>
                          <Height>740</Height>
                          <Width>800</Width>
                      </Size>
                  </Geometry>
              </UI>
              </DispatchInfo>
              </Extension>
              </DispatchInfoList>
            </ExtensionManifest>
            

             

            I'll have a look through myself as well to see if I can find anything. Just strange why it was working before I upgraded Windows.

             

            Thanks for your help. Also, thanks for pointing me to your CSTK tool. I can see this being really useful for trying out js/jsx code.