4 Replies Latest reply on Mar 28, 2008 6:58 AM by Philip Tory

    **$$PlaceHolder$$** appears where header should be in HTML Help topics

    Philip Tory Level 1
      I have been working on this Help Project for a client since 2004, updating it when they update their software.
      I recently upgraded to RH7, and have been working on an update on their Help project. When I build the HTML Help output this morning, the header was correct on only the first two topics; then on subsequent topics I was getting "Script Error" warnings.
      I went back into RH7 and checked for missing files etc - all OK.
      Then I did a menu > Tools > Update HTML Effects, which usually sorted out any misbehaviour or earlier versions. New compile to HTML Help. Again, the header is normal on the first two topics only, but on all the other (100+) topics, the header is replaced by text **$$PlaceHolder$$**.
      The header comprises a single cell table with a background graphic, and a small graphic within the cell itself.
      The two topics that display correctly are at top level in the ToC; all other topics are in Books in the ToC.
      I tried Browse Sequence set to Zero and set to 1, but same problem. I tried removing the browse sequence display from the output build, but same problem.
      Headers appear correctly in topic Preview mode.
      I tried removing the template from all topics and then reapplying it; then did a new build. When I try to run the Help Guide, I get the ToC pane in view OK, but the start topic is blank, and I have "Internet Explorer Script Error" dialogue:
      "An error has occurred in the script on this page.
      Line 29, Char 1
      Error: Object expected.
      Code 0.
      URL: mk:@MSITStore:D:\!Active%20clients\Client%20BP%20Sunbury\Client%20BPOSS%20Shipboard\BPOSS _Shipboard_CHM\BPOSS_SB_Help.chm
      Do you want to continue running scripts on this page?
      Yes/No."
      If I click Yes, the Help Guide runs OK with all headers in place.
      I can then select any other topic, and all is OK; if I select the Start topic, then I get the script error message again.

      HELP!! This is for a major client, and the Help Guide is not deliverable in this form.
      ------------------------
      SOLUTION: I think I found the cause of problem. I had a splash screen on the first topic, inherited from long ago. I removed it, did a rebuild, and now everything works OK. I then reinserted the Splash Screen, rebuild, and now OK.
      Conclusion: I think there is a BUG in *Update HTML Effects*.
      Please pass it on!