5 Replies Latest reply on May 31, 2008 12:36 PM by Ansury

    Error after closing window under Vista

    Ansury Level 3
      Nobody else seems to be complaining about this but EVERY time I close my Air app via the window close X button I get this stupid message from Vista. No kidding it stopped working, Winblows - I TOLD IT TO! lol

      Is there any way around this problem? Am I doing something wrong? I've tried nativeApplication.exit(0); and nativeApplication.autoExit = true; ..... same crap message.
        • 1. Re: Error after closing window under Vista
          enorton@adobe Level 1
          Hi Ansury,

          Is this every AIR application you've used or just one specific one? One that you are developing?

          If it's one that you are developing, perhaps you could try to simplify and isolate what is causing this.

          Thanks!
          -Erica
          • 2. Re: Error after closing window under Vista
            Ansury Level 3
            All of them. Even the most simple possible AIR application does this (a blank project that was just generated!) Figured maybe it was Vista's fault, but nobody else seems to complain about this.
            • 3. Re: Error after closing window under Vista
              Ansury Level 3
              Just noticed something pretty important. It's only happening when I run out of Flex Builder in DEBUG mode. Release mode works fine... also, if I KILL the process in debug mode (the red button by the console), I don't get this error message. I only get it when I close the window normally using the window-close X button.
              • 4. Re: Error after closing window under Vista
                enorton@adobe Level 1
                Hi,

                What exactly is the error message that you are getting? What version of Flex Builder are you running (Flex Builder 3 shipped or a labs version?) Is it installed on top of an Eclipse installation or as a standalone?

                Thanks!
                -Erica
                • 5. Re: Error after closing window under Vista
                  Ansury Level 3
                  This is Standalone FB3, installed from a CD.

                  Build: 3.0.194161

                  The error message I get is in a Windows (Vista) dialog box:

                  adl.exe has stopped working
                  (And then the usual standard rubbish about how a problem occurred and Windoze will notify you if it finds a solution... LOL)

                  This only seems to be happening in FB debug mode (starting the app by clicking the debug button instead of run), so I guess that makes it just a freaking annoyance. But is there a way to fix it? I'd be surprised if someone running vista, with an empty generated AIR windowed application doesn't get this message when they close the window.

                  Man, I hate Vista.