6 Replies Latest reply on Jul 20, 2018 5:27 AM by whiteship

    Images (.Jpeg's) showing at very poor quality on mobile.

    whiteship Level 1



      I have a problem with the image quality on mobile devices that I can’t get over for the past two weeks.


      The problem is that all images I use in any gallery are showing at very poor quality when they are viewed from any mobile device.


      I export the images .jpegs but they don’t seem to show at good quality no matter how I export them, except .png. They are showing up well if they are png’s but they are loading much slower.


      I used different galleries from different widget providers, all have the same result, so it’s not the galleries as I originally thought. I happened to change the hosting provider to a better one, same thing.


      What can I do to have .jpeg’s show at good quality on mobile? I am trying to avoid the .png option because it seriously affects the loading time.


      I am having this problem on two websites and I don’t know how to resolve it. Please help if possible…


      Thank you,


        • 1. Re: Images (.Jpeg's) showing at very poor quality on mobile.
          ankushr40215001 Level 7

          Hey George,


          There have been quite many discussions regarding this issue of blurry image in Phone devices in past, however the below thread is what explains it best.


          I suggest you have a at this and let us know if you still find any difficulties to resolve the issue. Blurry Image Problem.





          • 2. Re: Images (.Jpeg's) showing at very poor quality on mobile.
            whiteship Level 1

            Hello Ankush,


            Thank you for the quick reply. I've read the links you sent twice, because I've done some research before I asked the question and those links popped every time I searched.


            Every information I found refers to images placed in Muse directly or as backgrounds, etc. For example drawing a rectangle and placing the image as 'Fill'.


            However, I am using a gallery widget and I don't know if the widget name is relevant because it didn't work with other galleries/widgets either. The difference is that the images uploaded in the gallery container, are exported as assets, not in the images folder. The assets are .jpegs and they show at good quality on my iMac. In fact the whole website shows well on my iMac, but when I view it from my phone, the images are terrible, especially on 4G. Only the images I place directly on the canvas, or as a fill, are exported in the Image folder. I also have the RAW files of the images and I have exported them with different settings, optimized for web, etc etc. Nothing works.


            Thank you,


            • 3. Re: Images (.Jpeg's) showing at very poor quality on mobile.
              Günter Heißenbüttel Adobe Community Professional

              Place your Images without any scaling in Muse, and Muse won‘t even touch them. Input quality will be output quality. Besides this: in the link, which Ankush provided, you find some more links, which deal with this „issue“ very deeply.

              One additional hint: If you place an image, Muse will recalculate it for smaller breakpoints to save page loading time. You may optimize this process by hiding the slideshow in smaller breakpoints and  place a new slider, which of course is hidden in other breakpoints and contains optimized, unscaled images for these smaller breakpoints.


              If this doesn‘t provide a solution, do the following:

              Create a new .muse file with a slide show, containing only one image, which demonstrates your issue. Upload this small .muse file together with the original image to Dropbox, CC Files or a similar file sharing service and share the download link here.

              1 person found this helpful
              • 4. Re: Images (.Jpeg's) showing at very poor quality on mobile.
                whiteship Level 1

                Hello Gunter,

                I understand that muse won't touch your image if it is the exact size it has when placed in muse. For example if I want the photo to show up at 1014X1520 in a 2560px breaking point, I must export it at 1014X1520, right? 

                I have explained the problem in detail in the file I have attached, but here is a link as well:





                and the file:


                Dropbox - image-test.muse


                Sorry for all the information but it took some time to create that and I am still not sure if it is a good example. I also included other links as well.


                Thank you in advance,


                • 5. Re: Images (.Jpeg's) showing at very poor quality on mobile.
                  Günter Heißenbüttel Adobe Community Professional

                  Unfortunately I can’t help.

                  First of all, the images don’t show up (of course, because they are administrated by the widget itself and I don’t have the images in question)

                  Second: These are 3rd party widget, and we can’t say, how they are working internally. You should ask the vendor to solve your issue.

                  1 person found this helpful
                  • 6. Re: Images (.Jpeg's) showing at very poor quality on mobile.
                    whiteship Level 1

                    What do you mean the photos don't show up? They don't show up at all? I can send the original files if needed.


                    Also I have addressed this question to QooQee customer support since I originally thought it is their widget who is the problem and they said it's from Muse and how it handles the images. Then I tried a different gallery from a different vendor, with the same result. So I am running out of options here. Am I limited to only what Muse has to offer? Also, asking adobe was the last option because I tried to resolve the issue myself and did research, read entire forums and made tests after tests for over two weeks.


                    I am going to ask the same question to the other vendor and see what they say but I am afraid I am running in circles.


                    Thank you,