0 Replies Latest reply on Mar 24, 2008 12:08 PM by The Producer

    Need Flash Player 8 Install

    The Producer
      I need Flash Player 8 to run an older program that has not been updated. All the links I find online are redirecting me to 9 and the older version downloads file is not, for whatever reason, allowing me to install version 8.

      Thanks!

      Michael