7 Replies Latest reply on Mar 1, 2009 9:24 AM by johnoe

    Air refusing to install

    pyroonaswing
      Hey everyone,

      This had all started about a week or so ago when i had tried to install UniversalCallerID on my mac, and was given the error that "Installing may not be allowed by your administrator. Please contact your administrator." I assumed it had something to do with transferring my user account onto another computer, and then back onto this one. So I had verified disk permissions, repaired them, and uninstalled Air, but that had only made my problems worse because now I get the same error message when trying to install Air. Ive googled around for solutions, but nothing seems to be working for me. Here is the log file,

      Performing runtime install
      UI SWF load is complete
      UI initialized
      starting user confirmation
      Installation type: new
      starting elevated install
      subinstaller: starting install
      subinstaller: Scheduling runtime installation operations
      subinstaller: Beginning runtime installation
      subinstaller: Beginning install
      subinstaller: Copying /Volumes/Adobe AIR/Adobe AIR Installer.app/Contents/Frameworks/Adobe AIR.framework to /Library/Frameworks/Adobe AIR.framework
      subinstaller: Copying /Volumes/Adobe AIR/Adobe AIR Installer.app to /Applications/Utilities/Adobe AIR Uninstaller.app
      subinstaller: Error occurred; beginning rollback: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2038" errorID=2038]
      subinstaller: Deleting /Library/Frameworks/Adobe AIR.framework
      subinstaller: Rollback due to error complete
      subinstaller: error during install: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2038" errorID=2038]
      Failed during elevated install: error 2038 Error #2038
      runtime install entering error state: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="Error #2038" errorID=2038]
      begin quitting

      Im running Mac OS X 10.5.6 on a white intel iMac. (early 2006)

      Any help would be hugely appreciated. thank you.