4 Replies Latest reply on Jul 23, 2018 6:28 PM by drmdzh

    Can't import or open .puppet files

    drmdzh Level 1

      Character Animator is not recognizing downloaded .puppet files. I've tried opening, importing, dragging... nothing works. I am downloading them from Okay Sumurai Puppets - so they are the same puppets used in the tutorials.

       

      Any ideas? Thanks.

        • 1. Re: Can't import or open .puppet files
          SharonfromMD Level 2

          The only thing I would say is to save them first to your hard drive, if you can. Then try to import them. Just a guess.

          • 2. Re: Can't import or open .puppet files
            drmdzh Level 1

            Thanks, but they are already on my hard drive.

            • 3. Re: Can't import or open .puppet files
              alank99101739 Level 5

              Two problems come to mind: (1) the puppet download is corrupt, (2) your system is corrupt. (I guess (3) is user error! ;-)

               

              Do you have an existing puppet in a project? If so, why not try from the menu “Export / Puppet” and save somewhere. Then import that puppet file you just exported. If that works but the downloaded puppets do not, then something has gone wrong in the download process. (File got corrupted, truncated, etc.)

               

              If you like, try downloading a puppet file then post the URL of the download here. Then tell me the size of the file you downloaded and I can compare to what I get.

               

              I think *.puppet files are actually ZIP files with a different file extension. I was wondering if some tool like a antivirus checker spotted this and “did something” to the downloaded file as a “safety” mechanism. If you do your own export, that skips the download stage, so hopefully less would get in the way.

               

              The way I normally import puppets is I open/create a project then use control-I (Windows) to open up the import dialog box, then select the *.puppet file to import. Sometimes when using Google Drive for downloads it looks confusing because it seems to detect its a ZIP file and it shows me the contents of the file. Its important to not extract the contents of the ZIP (*.puppet) file - it must be a single *.puppet file on disk to work.

               

              Oh, have you tried any of the puppets/projects in the “Start” workspace? (There are 4 links by default in projects at the top of the window - Start, Rig, Record, Stream - these are default workspaces provided with new projects.)

              1 person found this helpful
              • 4. Re: Can't import or open .puppet files
                drmdzh Level 1

                Thanks all. I re-installed Animator (after trying a bunch of what AlanK suggested to no avail - and now it works. Thanks for the suggestions :-)