7 Replies Latest reply on Aug 1, 2018 12:29 AM by aralessbmn

    Frame rate issues with PNG image sequences

    aralessbmn Level 1

      To give some context, I use Adobe Flash/Animate to add animations to video footage. I'm not formally trained, so I've been figuring it out as I go.

       

      My process: I'll trim a video file down to several small clips and embed a clip into the Animate timeline. I'll animate some scenes, and export the scenes as a PNG image sequence. I'll then import those image sequences into Premiere Pro and sync it up with the original video file. The end product looks really cool.

       

      I'm having a particular difficult time with the current project though. The original video file is 29.97 fps, I trim them into clips that are 29.97 fps, and I put them into an Animate project that is 29.97 fps. I don't see any way to control the way it's exported, but when I import the image sequence into a Premiere Pro project that's timebase is at 29.97, they show up by default as 24 fps. I change the default to "assumed frame rate" and mark it as 29.97, but there's a huge discrepancy between the image sequence and the original video file.

       

      Here's a picture of the image sequence in the timeline at its default 24 fps. If everything was working correctly, it would match up perfectly with the clip right below it.

      Screen Shot 2018-07-29 at 11.06.19 PM.png

       

      Now I've changed the settings on the image sequence, to an assumed frame rate of 29.97. That's the frame rate of the project and the clip right below it. Again, they should match up perfectly. Somehow they don't even come close.

       

      Screen Shot 2018-07-29 at 11.06.55 PM.png

       

       

      I'm tearing my hair out on this one. Maybe this is more convoluted than it has to be, and someone can suggest an easier way? I can't figure out what I'm doing wrong here. Everything should be at 29.97 fps, but it's not.

       

      Any help you can give me would be greatly appreciated; I'm sort of under a time constraint here. This is work for a client.

        • 1. Re: Frame rate issues with PNG image sequences
          yenaphe Adobe Community Professional

          Hi,

           

          in the second screenshot, your clip seems to not be extended to it's full length (it is missing the small notch on the upper right corner. So my first guess would to try to extend your clip.

           

          Also, there's a setting that is going to help you. In edit > preferences > Media, you can set the Indeterminate Media Timebase paramater to 29.97 instead of 24. That way, your png sequences will be interpreted as 29.97 by default

           

          Hope this helps,

           

          Seb

          2 people found this helpful
          • 2. Re: Frame rate issues with PNG image sequences
            aralessbmn Level 1

            Hey Yenaphe,

             

            I wish that did help. The clip in the second screenshot is indeed fully extended. I changed the indeterminate media timebase to 29.97; it was at 24fps. Unfortunately, it didn't help. The image sequence is now coming in as short, just like in the second screen shot. I can't figure out what is going on here. Something between importing the video clip into Animate and exporting the image sequence is screwing with the frame rate. I am trying to animate over the existing video, so they need to be synced up. I cannot for the life of me figure out what the problem is. All of the projects are set at 29.97 fps, and all the files SHOULD be 29.97 fps, but they're not syncing up.

             

            Is there anything else I may be missing?

            • 3. Re: Frame rate issues with PNG image sequences
              R Neil Haugen Adobe Community Professional & MVP

              Try this in a new project file with the indeterminate time settings at 29.97. I think after adding those in at 24, PrPro is still seeing them as that internally.

               

              Neil

              • 4. Re: Frame rate issues with PNG image sequences
                aralessbmn Level 1

                I just created a new project in Premiere and set the indeterminate frame rate at 29.97, and a new Adobe Animate project with the frame rate at 29.97. I dropped a new video clip into Animate, which is at 29.97 fps. I then exported that as an image sequence. I imported the image sequence, and also dropped the original video file into the library. When I look at the properties, they both show a 29.97 frame rate. However the image sequence is 12:08 seconds, and the original video file is 12:21 seconds.

                 

                You may think the image sequence is missing frames, but it's not. It has all the same information as the original video file. It starts and ends the same way. But it is playing at a different rate. Which doesn't make any sense if it's at 29.97 fps. I can't seem to get them to sync up no matter what I do; whether I try and slow it down using the speed control, or changing the frame rate.

                • 5. Re: Frame rate issues with PNG image sequences
                  yenaphe Adobe Community Professional

                  Very weird indeed.

                   

                  Could you share your project with the png and video file so we can test it on our side see if we can fgure something out?

                  • 6. Re: Frame rate issues with PNG image sequences
                    Jim_Simon Level 9

                    I wonder if the difference you're seeing is Drop Frame/Non Drop.

                    • 7. Re: Frame rate issues with PNG image sequences
                      aralessbmn Level 1

                      Thank you everyone for taking time out of their days to help me out. I came across a slightly more time consuming but much more effective fix. Instead of trimming the original video file down to smaller clips, then dropping them into Animate, I'm going to be exporting out of Premiere as image sequences. If I import those images into Animate and distribute them to keyframes, I can animate and then export as another image sequence. When I import back into Premiere, everything syncs up perfectly!

                      1 person found this helpful