9 Replies Latest reply on Sep 12, 2018 8:29 AM by kathym20447758

    Cannot repair corrupt catalog

    mtimko

      I encountered an error when loading photos into Lightroom CC and the import failed, since then I have encountered "corrupt catalog" errors and the repair dialog errors as well.  I do not have a backup of this catalog for the last week.  Can it be repaired?  Please help!

      Screen Shot 2018-08-10 at 11.55.13 AM.png

        • 1. Re: Cannot repair corrupt catalog
          mtimko Level 1

          Sahil.Chawla can you help?

          • 2. Re: Cannot repair corrupt catalog
            Mohit Goyal Adobe Employee (Admin)

            Hi mtimko,

             

            We're really sorry for all the trouble. Since how long you are facing issue?

             

            Also, could you please let us know the exact version of Lightroom you are using now? Go to Lightroom > help menu > system info.

             

            Regards,

            Mohit

            • 3. Re: Cannot repair corrupt catalog
              mtimko Level 1

              Hi, thank you! I am using Lightroom CC 7.4.  I am only able to open LR for about 10 seconds before it shuts down.

              • 4. Re: Cannot repair corrupt catalog
                Mohit Goyal Adobe Employee (Admin)

                Thanks for the update. Were you migrating the Lightroom 5 catalog to Lightroom 7.4 and you got the error?

                 

                When this catalog was working fine? Do you get to the library module when you launch the Lightroom?

                 

                Regards,

                Mohit

                • 5. Re: Cannot repair corrupt catalog
                  mtimko Level 1

                  No, I was uploading photos and ran out of hard drive space during the import.  Lightroom shut down at that time.  I cleared 150gb of space on my hard drive and have still been unable to complete the catalog repair.  I believe the catalog is up to date, it's the same one I have been using for several years and I have always followed instructions on updating the software & catalog through Adobe CC.  It has worked fine previously until it became corrupted through the image import process when I ran low on hard drive space.

                  • 6. Re: Cannot repair corrupt catalog
                    cmgap Adobe Community Professional

                    Do you have a recent backup? If yes - it might be more productive to unzip it and open it to see if that works.

                    • 7. Re: Cannot repair corrupt catalog
                      mtimko Level 1

                      My most recent backup is a week old and that is why I'm trying to repair this catalog.  I created a new catalog so I can go in and change settings if need be, but my goal is to restore the catalog that is currently corrupted.

                      • 8. Re: Cannot repair corrupt catalog
                        ronaldd56392149

                        I just saw this post today (8/24/18) and have the same problem.  I run LR Classic v 6.:

                        " LR Cannot Repair Corrupt Catalog;

                                       Unfortunately, the catalog named "my catalog name"  cannot be repaired".

                                       Please use a recent back-up copy of this catalog or contact Adobe Support to troubleshoot and resolve this issue.

                                       Buttons for:

                                          Contact Adobe Support

                                          Show in Explorer

                                          Choose a Different Catalog

                                          Exit

                        My Problem is, the (recent) back-up catalogs are also corrupt.and cannot be repaired?  (How can Choose a Different Catalog resolve this specific database issue).  I'm very surprised  and disappointed that Adobe hasn't written a code or update to address this old/common program issues.  By the way,  my desktop computer, external storage hard-drive and back-up drive are all working fine.

                         

                        I just need some help or suggestions on how to restore/repair the Corrupt Catalog so I regain critical access to my large photo library.

                        • 9. Re: Cannot repair corrupt catalog
                          kathym20447758

                          mine is a brand new   catalog, no back up as it is new portable disk with a new trip.  can't get it to work.  Worked great for a couple times ( ie transferring my pictures and organized folders.   I worked with 6 pictures last night  and now can't use it, won't repair and can't optimize.  there is no back up