3 Replies Latest reply on Mar 31, 2008 7:19 AM by Ben Minson

    TOC Topic content not displayed in WYSIWYG Editor

    SSuj
      I use RoboHelp X5. When I click a topic in the TOC pane I expect to see its contents displayed in the WYSIWYG Editor. Instead the WYSIWYG pane is grey and the TrueCode pane is blank with a cursor flashing on the upper left corner!

      I searched for some similar issue on this forum and could not find it. However, I did gather that I could use another editor by right clicking a topic when in the Project tab and selecting one of 5-6 editors. I tried RoboHelp TrueCode and was amazed and relieved to see the code and content for the topic displayed in the TrueCode pane...so I went a step further and tried the WYSIWYG editor and wonder of wonders, the topic content was displayed.

      Can someone please tell me what is going on? Should I reinstall RoboHelp X5? Why does the topic content not display when I click the topic from the TOC tab?
        • 1. Re: TOC Topic content not displayed in WYSIWYG Editor
          Peter Grainge Adobe Community Professional (Moderator)
          Welcome to the forum.

          There have been posts about this but maybe your forum search history is not set to go back far enough.

          Rather than right click and selecting RH True Code, at the bottom of the editing pane there is a true code tab which will quickly enable you to see your code is still safe. That said, if you then click WYSIWYG, you don't get the view restored, usually. Maybe your way has an advantage.

          It's one of those things that happens now and again. I don't think reinstalling will help. I have had it happen several times in a day and then you go months with it working just fine.

          I don't believe anyone has ever lost any data. At worst you just have to close RH and reopen it.

          For what it is worth, I haven't seen this happen in RH7.

          • 2. Re: TOC Topic content not displayed in WYSIWYG Editor
            RoboColum(n) Level 5
            As Peter has said, this is an occasional issue for some (but not all) users that is a minor irritance rather than a major problem. Personally I've had it only a handle of times and I've used RHX5 since it came out. No one has ever really got to the bottom of the issue. It maybe some sort of refresh issue. Are your project source files stored locally? If not, this may be part of the issue.
            • 3. Re: TOC Topic content not displayed in WYSIWYG Editor
              Ben Minson Level 2
              I remember in previous threads on this that the blank topic problem happened for some people when they tried to open topics out of the TOC rather than the Topics list in the Project Manager. Opening out of the Topics list may be more reliable.

              --Ben