9 Replies Latest reply on Aug 25, 2018 7:39 PM by joker7788

    Edit in Photoshop Command does nothing

    joker7788

      Hi there, I am struggling with this glitch I am having.  I have Creative Cloud for both Lightroom CC and Photoshop CC, and should be updated.  LR CC is version 7.5 and PS CC is 19.1.6.  I am running a Mac, High Sierra 10.13.6.  I have checked with both CC and Apple to check for updates and both services are telling me that they are up-to-date.  Both LR and PS work fine independantly, I just can't seem to get them to work together.  I did have the problem where the options were greyed out after the Edit in drop-down under the Photo tab, but a reset on my Mac fixed that.  Now it is highlighted like I can use the function but it won't open PS.  I don't know if it ever worked before I am only now starting to use PS for editing, my normal work flow is only LR.  Any help or thoughts are much appreciated, TIA.

        • 1. Re: Edit in Photoshop Command does nothing
          gary_sc Adobe Community Professional

          Hi Joker,

           

          I sometimes have that issue. At a minimum I find that it's very slow. When I've done my Command-e, I will wait a moment and then tap on the PS icon and wait another moment and eventually the image is there to work with.

           

          I'm also running HS, X.1.6 but I'm on a 5K iMac. Otherwise we're pretty much the same.

           

          There have been times when I've tapped out Command-e, then again, and when I finally check out PS I find several copies of the image have been there waiting for me.

           

          Beyond that I cannot help you, sorry.

          • 2. Re: Edit in Photoshop Command does nothing
            joefry99 Adobe Community Professional

            A quick survey on the internet suggests a few things to check/try:

            0) Does it do it on all pics? Try a "clean" one  - not synced or anything else funny.

            1) resetting Photoshop preferences.

            2) Previous versions of Photoshop interfering? Photoshop: Won't edit from Lightroom CC after latest update | Photoshop Family Customer Community

            3) try loading Photoshop on top of itself: Photoshop CC 2015 won't load after update June 16th 2015 | Photoshop Family Customer Community

            • 3. Re: Edit in Photoshop Command does nothing
              WobertC Adobe Community Professional

              There is a 'Help' page at- 'Edit In Photoshop' command missing

               

              When the "Edit In" menu items are 'greyed out' it can mean-

              1) There is no image selected.

              2) The original photo file is 'missing' (location unknown to LR) or the photo file has been deleted.

              3) LR only has access to Smart Previews. (Originals are not available.)

              1 person found this helpful
              • 4. Re: Edit in Photoshop Command does nothing
                joker7788 Level 1

                Hi Gary,

                 

                Thanks for the reply.  When trying it, I did wait for a short time for PS to open up on it's own.  And when I opened up PS manually the image was not there so I'm still going to be scouring the web for a fix.  Cheers Joe

                • 5. Re: Edit in Photoshop Command does nothing
                  joker7788 Level 1

                  Hi WobertC,

                   

                  Thanks for link.  Following those instructions, I deleted the plist file from my library and reinstalled photoshop, and now it works for some of my images.  I'm not sure if it made a difference or not, but I have done a quick test on some of the other days that I have images on and it worked flawlessly.  Problem seems to be with all the images imported on a specific day.  The edit in PS is now all greyed out for all the images taken on that 1 day, where as the other images taken open in PS fine. I have copied and made comments to your 3 possible reasons, can you help me out with them?  Thank you

                   

                  When the "Edit In" menu items are 'greyed out' it can mean-

                  1) There is no image selected.  I believe I have tested this out by picking/using other images and it worked

                  2) The original photo file is 'missing' (location unknown to LR) or the photo file has been deleted.  I did move some files around on my portable hard drive but I don't have any question marks on the location of the files....that should mean that LR knows the location correct?

                  3) LR only has access to Smart Previews. (Originals are not available.) If this is the case, can I change those images to have the standard preview versus smart previews after an import?  Is it better to have the build the smart previews box checked or not so I can avoid this problem again?

                   

                  Thanks again

                  Cheers Joe

                  • 6. Re: Edit in Photoshop Command does nothing
                    joker7788 Level 1

                    Hi Joe,

                     

                    Thanks for advice.  I did try to open an unedited image and some other images from different days, and it did work.  The problem is that all the images that I imported from 1 day are the ones giving me grief.  The open in photoshop option is either greyed out or won't open with the command.  So I following another suggestion I deleted the PS plist file from my preferences and did the uninstall - reinstall of PS, which fixed the issue with the images beside the 88 images taken on 1 day.  Now that I know it works I have to figure out what the problem is with the images taken on that particular day.  Thanks for the help you got me going in the right direction.

                    Cheers Joe

                    • 7. Re: Edit in Photoshop Command does nothing
                      joefry99 Adobe Community Professional

                      So it works with Photoshop editing now in general but you're having a problem with specific images. Would you mark this request as fixed, and open another issue? I have some suggestions for that but want to fight against "issue drift" - your new problem is only limited to something going on with specific images.

                      • 8. Re: Edit in Photoshop Command does nothing
                        joker7788 Level 1

                        Yes sorry I would say it is fixed.  I will mark it as so and pop open another message.  Thanks, I look forward to your thoughts Joe

                        Cheers Joe

                        • 9. Re: Edit in Photoshop Command does nothing
                          WobertC Adobe Community Professional

                          I did move some files around on my portable hard drive

                          If you did this with the operating system file browser, then YES, Lightroom thinks your photos are "missing"- They are not in the Folder where the Lightroom database (Catalog) believes them to be.

                          "Missing" photos will show the ! icon on the thumbnail border.

                          ScreenShot103.jpg

                          How To fix: Read the article at- https://www.lightroomqueen.com/lightroom-photos-missing-fix/

                           

                          And you cannot 'Open' or Edit photos in Photoshop if Lightroom does not know where they are located.