6 Replies Latest reply on Feb 3, 2008 11:07 PM by dsarig

    Glossary trouble

    dsarig Level 1
      In our generated WebHelp, an entry appears in the Glossary: "Enter new glossary term here". (It even appears in alphabetical order in the Glossary.) This entry does not appear in the CHM of the same project. We do not have an entry like that in the Glossary. I checked the entry before it and after it, and those words do not appear in those entries. I have also checked the .glo file and those words do not appear there. Any ideas why this is happening?

      Thank you,
      Debbie
        • 1. Re: Glossary trouble
          Captiv8r Adobe Community Professional & MVP
          Hi Debbie and welcome to our community

          Are you able to provide us with a link to your output so that we might see?

          What version of RoboHelp? What RoboFlavor? RoboHelp for Word or RoboHelp HTML?

          Very odd to say the least... Rick
          • 2. Re: Glossary trouble
            dsarig Level 1
            Thanks for the welcome. The WebHelp is at: http://ftp.magicsoftware.com/www/help/iBOLT/Startup.htm
            If you then click the Glossary button at the top, you will see that in the left-hand pane there is an entry "Enter new glossary term here".

            Thanks,
            Debbie
            • 3. Re: Glossary trouble
              RoboWizard Level 4
              Hi again

              Thanks for the link. I don't believe I've ever seen WebHelp behave that way before.

              So once again, what version of RoboHelp are you using? And is it RoboHelp for Word or RoboHelp HTML? And is it WebHelp or WebHelp Pro? By chance are you also merging WebHelp? I suppose that may also account for possibilities here.

              Cheers... Rick
              • 4. Re: Glossary trouble
                dsarig Level 1
                Hi Rick,

                I'm using RoboHelp 6. This is RoboHelp for HTML. WebHelp (not Pro). It is a merged WebHelp that is structured as outlined on Peter Grainge's site.

                Regards,
                Debbie
                • 5. Re: Glossary trouble
                  RoboWizard Level 4
                  Hi again Debbie

                  Okay, if memory serves, the information on Peter's site has you creating an overall parent project. The single project doesn't really have anything inside. It essentially serves as a shell to house all the child projects.

                  My suspicions are the parent project. I'm guessing that because the Glossary is enabled and nothing exists for the parent, you are maybe seeing an entry that RoboHelp is popping in there as a default, since nothing is probably defined in the parent. I suppose one way to confirm my theory would be to simply add a single term to the Glossary of the Parent project. Something really wacky, such as Boffo or RedRabbit (I think RedRabbit is one of Peter's favorite terms). Then generate again and see if the default mysteriously disappears.

                  Give that a go and keep us posted on the outcome.

                  Cheers... Rick
                  • 6. Re: Glossary trouble
                    dsarig Level 1
                    Problem solved. Thank you Rick. I checked the .glo file in the parent project and there was an entry there called "Enter new glossary term here". However, once I removed it and then had an empty glossary file, the glossary did not appear in the generated merged project (the glossary option was not available for selection in the parent project). So, I copied one of the glossary entries from the child project into the parent project and then it worked fine.

                    Thanks again,
                    Debbie