12 Replies Latest reply on Dec 5, 2018 1:21 PM by annemettekuhl

    Watermarks not appearing

    catherinee70709450

      I've set up a watermark. When I export photos, I tick the watermarking box. Nothing appears on the photo! I've tried several times, also checked for updates, as suggested by Adobe.

      I did added watermarks fine a few months ago (with the same watermark), no idea what's going wrong this time.

        • 1. Re: Watermarks not appearing
          Jao vdL Adobe Community Professional & MVP

          What kind of watermark are you using? If it is the "simple copyright watermark" it gets its info from the copyright field in your photo's metadata and if that is not set, it will not export anything. Also, if you export at original size, this simple copyright watermark can end up being very small and almost invisible.

          • 2. Re: Watermarks not appearing
            catherinee70709450 Level 1

            Thanks. I added it in >edit >edit watermarks. No idea what type of watermark that makes it, there doesn't seem to be a different option to the one I used?

             

            I've never gone into the metadata of any of my photos, and I've managed to download them with watermarks fine before so I'm not sure it's that.

            It could be worth trying setting copyright info to the metadata though (maybe Lightroom has changed something since I last did this 6 months ago?) - how do I do that?

            • 3. Re: Watermarks not appearing
              Jao vdL Adobe Community Professional & MVP

              In the export panel, where you click on the watermark option, there will be a popup next to the watermark checkbox. Make sure it has your watermark selected. If it says "simple copyright watermark" in that popup it just takes the metadata in the copyright field. This is set in the metadata panel in the library view. Make sure it says "Default" left of the word Metadata and you will see a copyright field that you can fill out. I have this always populated by using a metadata template on import that makes sure to populate this field with my name for every imported image. That way it is always included in the metadata on any exported image and gets imprinted on any exported image if I select the "simple copyright watermark" option.

              • 4. Re: Watermarks not appearing
                annemettekuhl

                I seem to have a similar problem.
                Since I updated to Lightroom 8 Classic CC it wont add my watermarks anymore.
                I have used watermarks in Lightroom always and know my way around creating them and adding them to my photos - web-files/jpeg-files - but when I create a watermark (on the preview it looks just fine) it doesn't show on my exported jpegs.

                • 5. Re: Watermarks not appearing
                  davidg36166309 Level 4

                  Working on my copy

                   

                  Lightroom Classic version: 8.0 [ 1193777 ]

                  Operating system: Windows 10 - Business Edition

                  Version: 10.0.17134

                  DirectX: NVIDIA GeForce GTX 1070 Ti (23.21.13.8843)

                   

                  By showing up in your JPEG preview, I take it you accomplished an export within LR,and the exported file as seen in LR shows the watermark.

                   

                  Then you export it or shall we say publish it, and no watermark?

                   

                  Please list your steps, I am clearing missing something.

                   

                  My steps normally would be work on my RAW, when I am happy with it, I might export it as a TIFF to work on in third party apps (NIK?), When finally done, I use the Publish service in LR to publish to Smugmug (and I will have add the WM at this point), in that situation I do not wind up with a JPEG in my catalog. Now, and this may relate more to what your workflow is, if I want to share on Facebook, as the Facebook Publish Service no longer works (Oh, don't blame Adobe, thats all on Facebook), yes, I will export to a JPEG and I will include my watermark. And it is working. I see the watermark in LR, I see the WM on FB.

                   

                  P.S. just ran a test, one export to JPEG, WM in LR Ok, looked at image in windows Photos, yes WM

                  • 6. Re: Watermarks not appearing
                    annemettekuhl Level 1

                    Thank you for your reply!

                    My steps to adding the watermark in export are as follows:
                    My edited photo is done and ready for export. I had different working presets of exporting to a folder on my desktop, from where I publish. Those presets are gone because of a long story - including me upgrading to LR CC CLassic 8 - so I have made new export presets.
                    I made two new export-presets to export the photos - one as a web-file (92 ppi, 30 cm on long edge and with a rather big text-watermark created and saved in watermark editor)
                    The other a watermark for print-files (310 ppi, 30 cm long edge with a small text-watermark)
                    I choose a preset, then hit Export - and when I open the exported file in my desktop folder, it has no watermark!!
                    I have been back and forth to see where the problem might lie and I cant figure out where the difference is. I have tried to change the Copyright metadata of the photos - even though that never was an issue before my upgrade....it didn't help any.
                    I tried to export a different file - no difference.

                    I tried closing down LR and restarting it.
                    etc.
                    Since my upgrade I've also had issues when I want to edit my files in PS CC 2019 - I can't edit the photos in PS when I export directly from LR to PS! I have to open PS up before hitting "Edit in PS CC 2019" - I was told that was a LR-bug....
                    ....hope all this makes sense and the watermark issue can be easily solved!

                    • 7. Re: Watermarks not appearing
                      Jao vdL Adobe Community Professional & MVP

                      So you are using a text-based watermark and not the simple copyright watermark?

                       

                      I just tried and made a new text watermark using the watermark editor and generated two presets that use it - one that exports at 92 ppi, 30 cm long edge and and one at 300ppi, 30cm long edge. The watermark comes out perfectly on both.

                       

                      watermark editor:

                      Untitled.jpeg

                      Low res:

                       

                      DSC_5082.jpg

                      High res:

                      DSC_5082-2.jpg

                      • 8. Re: Watermarks not appearing
                        annemettekuhl Level 1

                        I see Jao - you're lucky to be able to do just that!
                        - BUT that did not help me solve my problem!

                        • 9. Re: Watermarks not appearing
                          Jao vdL Adobe Community Professional & MVP

                          I put the screenshot of the watermark settings so you could compare what happens if you do the exact same thing. Same font, same size, etc. That might help you narrow down the problem. Also recreate the export preset using the new watermark you create.

                          • 10. Re: Watermarks not appearing
                            davidg36166309 Level 4

                            If you are choosing the copyright metadata for watermark, then that’s asking for trouble, perhaps you did not mean to imply you were, if nothing is in the metadata for copyright, and their is more than one field for this, then nada.

                            • 11. Re: Watermarks not appearing
                              WobertC Adobe Community Professional

                              One thought- What font are you using?

                              Not all OS fonts will work with Lightroom- I have found, and I do not know why!

                               

                              Some 'old' links for example-

                              lightroom fonts

                              Adding a font to Lightroom Classic

                              1 person found this helpful
                              • 12. Re: Watermarks not appearing
                                annemettekuhl Level 1

                                So it actually turns out when I went in thru "Edit" to "Edit Watermarks" and made my watermark-settings there, I found out that the font I was trying to use wasn't showing in the preview....so obviously not working! This was the case with a couple of fonts - all Italic!!

                                This did not show when I was making my watermarks in the Export-dialog - thru "Watermarking" - "Edit Watermark" - here the preview of the fonts not working were fine!

                                Long story short - it seems t be working again!

                                Thank you all for the feedback - I appreciate your help!

                                -Annemette