2 Replies Latest reply on Sep 18, 2018 12:58 AM by ramandeeps46023719

    Not able to fetch iphone device details using device plugin in phonegap

    ramandeeps46023719 Level 1

      I have used this plugin <plugin name="cordova-plugin-device" />, but I am not able to fetch device details of iphone.

        • 1. Re: Not able to fetch iphone device details using device plugin in phonegap
          José Jesús Pérez Rivas Adobe Community Professional

          Hi @ramandeeps46023719

           

          Are you compiling locally or remotely with PhoneGap Build?

           

          Can you share the code of your config.xml file to see if you have an error?

           

          Regards!

          • 2. Re: Not able to fetch iphone device details using device plugin in phonegap
            ramandeeps46023719 Level 1

            Hi

             

            I am using fcm plugin for push notification but getting error in android build.

             

            Found com.google.android.gms:play-services-auth:+, but version 9.0.0 is needed for the google-services plugin.

            Found com.google.android.gms:play-services-identity:+, but version 9.0.0 is needed for the google-services plugin.

            :processDebugGoogleServices FAILED  FAILURE: Build failed with an exception. 

            * What went wrong:

            Execution failed for task ':processDebugGoogleServices'. > Please fix the version conflict either by updating the version

            of the google-services plugin (information about the latest version is available at

            https://bintray.com/android/android-tools/com.google.gms.google-services/) or updating the version of com.google.android.gms to 9.0.0.

              * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

            BUILD FAILED  Total time: 1.92 secs Command finished with error code

            1: /project/gradlew cdvBuildDebug,-b,/project/build.gradle,-Dorg.gradle.daemon=true,-Dorg.gradle.jvmargs=-Xmx 2048m,

            -Pandroid.useDeprecatedNdk=true Error: /project/gradlew: Command failed with exit code 1 Error output:

            Note: Some input files use or override a deprecated API. Note: Recompile with -Xlint:deprecation for details.

            Note: Some input files use or override a deprecated API. Note: Recompile with -Xlint:deprecation for details.