2 Replies Latest reply on Oct 29, 2018 12:36 PM by pumphouse51

    Stuck Syncing 1 Photo

    pumphouse51 Level 1

      This is yet another description of what seems to be some related problems syncing from Lightroom Classic 7.5 to Lightroom CC.  I apologize for the repetition, but I believe I've tried all the diagnosis and remedy techniques mentioned on this and other forums. The problem has been occurring and re-occuring as I add synced collections to the web.

       

      I've tried to be methodical and I now have the identity of one (possibly typical)  photo that simply refuses to upload from Classic to CC for me.

       

      I started by changing all my synced collections to non-synced and removing all photos from the "All Synced Photographs" collection.   I verified this by going to Lightroom Web and seeing no synced colllections as well as a zero count in "All Photos".

       

      Then I slowly started re-syncing the collections.  At first, no errors, and the count on LR Web matched the count in "All Synced Collections".   Then I synced a collection that contained 12 photos produced with a scanner from old prints and negatives.  That resulted in 5 photos synced (all JPGs) and 7 TIFs with "Sync Pending".   Even after a day, no change.    I then removed 6 of the TIF photos that refuse to re-sync, there still is one photo of about 17.1 Megabytes size "stuck".  (I know only the "smart preview" goes up to CC, so I used Library->Previews->Build Smart Previews on it just in case.  No change.)

       

      What is very strange is that the sync status displays within LR are inconsistent.  The upper left hand banner area says "Syncing 1 photo", but the Edit->Preferences->Lightroom Sync says "0 Uploading, 0 Downloading, 0 Pending".  The sync icon in the photo's upper right hand corners says "Sync with Lightroom CC Pending".

       

      Lightroom CC (both Web and Android) shows no photos syncing and the photo does not exist on the web.  The "All Photos" count in CC is one less than the size of the Classic "All Synched Photographs" collection.

       

      I've tried the "Rebuild Sync Data" button with and without removing the sync.lrdata folder. When I removed the folder, I

       

      Problematic sync problems (both silently stuck and with "bad argument" errors) have been scans in TIFF format from an older Epson flatbed scanner imported originally into Photoshop Elements 8.   But most such photos sync fine.  The file that won't sync now is one such TIFF file.   I suspect there is something funky about the metadata originally authored in Elements and then converted to an earlier Lightroom version.

       

      Llightroom Classic up to date (7.5) with the Photography Plan subscription.  Windows 10, 64 bit.

        • 1. Re: Stuck Syncing 1 Photo
          pumphouse51 Level 1

          Some progress made.  

           

          In my scanned photo, the "Capture Time" was blank.  (Inscrutably, that shows as "12:00:00 AM" on the Metadata Panel. I determined the value was blank using Jeffrey Friedl's online Image Metadata Viewer.)  I changed it to have a real value of 12:00:01 PM and it very quickly synced.

           

          Now I just need to find all my photos with blank or 12:00:00 AM Capture Time.  I see no obvious way to do that. I'll look at John Ellis' "Any Filter".

          • 2. Re: Stuck Syncing 1 Photo
            pumphouse51 Level 1

            I'm going to mark this as "Correct Answer".   I've applied the fix (Change 12:00:00 AM Capture Time to 12:00:00 PM) to several photos I've had sync problems with and it cleared the jam.

             

            I hope Adobe can make Sync from Classic to CC more tolerant of bad data (missing Capture Time in this case).