2 Replies Latest reply on Sep 28, 2018 5:11 AM by dj_paige

    Lightroom & MAC High Sierra

    KRM0258

      I have an older version of Lightroom (v5.4) and want to upgrade to v5.7.  I've heard this doesn't work well or at all on High Sierra.  Has anyone had experience with this problem or do I just need to breakdown and purchase an upgrade.  Thanks for any suggestions.