4 Replies Latest reply on Oct 7, 2018 3:40 PM by mlberube

    Error launching ON1 Plugin

    mlberube Level 1

      Recently had to reinstall Windows 10 and thus all applications including Lightroom CC and ON1 Photo 10 suite. When I try to send an image to edit in any of the ON1 modules by right-clicking on the image I get the following message. "Lightroom was unable to prepare the selected file at F:\Photos\.......\IMG_0014.CR2 for editing. It will not be opened." I receive a similar message when I try to open via the FILE...PLUGIN-EXTRAS menu option which says "AgNegative:renderToFile:<AgErrorID>dng_error_write_file</AgErrorID>" . Accessing the plugin from Photoshop CC works fine.

       

      Please see my other post relating to the inability to import new photos. I suspect these two issues are related.

        • 1. Re: Error launching ON1 Plugin
          WobertC Adobe Community Professional

          Questions-

          The photo file at-  F:\Photos\.......\IMG_0014.CR2   

          Does the Catalog show the Preview with the 'missing' icon  [ ! ] ?

          Does it exist? Can you locate it in Windows File Explorer?

          Can you Right-click the photo in the Lr library grid and choose [Show in Explorer] ?

          When found, can you check the Properties/Attributes of the photo file and its containing folder? (It cannot be checked as Read-Only or Hidden)

           

          You might also check the "Additional External Editor" presets in the Preferences dialog to see if the ON1 Preset has the wrong location for the ON1 software .exe file.  Or re-install the "plug-in".

           

          Your other question also sounds like a Read/Write permissions problem, if you cannot save photos to the drive specified as the Destination.

          1 person found this helpful
          • 2. Re: Error launching ON1 Plugin
            mlberube Level 1

            Does the Catalog show the Preview with the 'missing' icon  [ ! ] ? NO

            Does it exist? Can you locate it in Windows File Explorer? YES

            Can you Right-click the photo in the Lr library grid and choose [Show in Explorer] ? YES

            When found, can you check the Properties/Attributes of the photo file and its containing folder? (It cannot be checked as Read-Only or Hidden) EXCEPT FOR USER EVERYONE, THE PERMISSIONS ARE FULL INCLUDING WRITE.

             

            You might also check the "Additional External Editor" presets in the Preferences dialog to see if the ON1 Preset has the wrong location for the ON1 software .exe file.  Or re-install the "plug-in". REINSTALLED PLUGIN WITH SAME RESULTS. ALSO, UNDER LIGHTROOM'S PLUGIN MANAGER, ALL ON1 PLUGIN MODULES ARE SHOWN AS INSTALLED AND RUNNING WITH A GREEN LIGHT. ON1 PLUGIN WORKING FINE IN PHOTOSHOP.

             

            Your other question also sounds like a Read/Write permissions problem, if you cannot save photos to the drive specified as the Destination

            1 person found this helpful
            • 3. Re: Error launching ON1 Plugin
              WobertC Adobe Community Professional

              All good answers as far as I can see.

              I do not have ON1 products, so cannot contribute much more, sorry.

              You could also give full permissions to "Everyone" and try that.

              Have you checked your Catalog 'Integrity' (as suggested in another thread)

              Have you researched the support at ON1?

              Launching ON1 Plug-ins inside Adobe Lightroom – ON1 Support

              How to manually add the Lightroom Plug-in – ON1 Support

               

               

              • 4. Re: Error launching ON1 Plugin
                mlberube Level 1

                Underlying issue was with my user account in my newly reinstalled Windows 10 did NOT have administrator privileges. Launching Lightroom with administrator privileges solved all my problems. Now I need to make my user id run as administrator permanently.

                1 person found this helpful