6 Replies Latest reply on Oct 6, 2006 10:03 AM by Captiv8r

    Opening CHM with HTMLHelp from MFC

    LarEpp
      I am having trouble with the topic not being selected in the TOC tree when I call HTMLHelp to a page in my CHM from an MFC application. I have another CHM that was not created with RoboHelp that works. Is there a setting in RoboHelp that I am missing for CHM compiles that allow this to work? Is anyone else having this problem? Please help! (no pun intended :-) )
        • 1. Re: Opening CHM with HTMLHelp from MFC
          RoboWizard Level 4
          Hi LarEpp

          There are two places you look.

          1. Expand the Windows folder and double-click your default window. Down in the lower left corner of the Window Properties dialog is an area labeled Tri-pane Options. Click to place a check mark in the Auto-synchronize TOC. Click to place a check mark there and close the dialog.

          2. Now expand the Single Source Layouts area. Right click the Microsoft HTML Help layout and choose Properties. Click the Advanced... button. Now the TOC Styles tab. Place a check mark in the "Always Show Selection" check box. Dismiss all dialogs, compile and test!

          Hope this helps some... Rick
          • 2. Re: Opening CHM with HTMLHelp from MFC
            LarEpp Level 1
            THANK YOU THANK YOU THANK YOU!!!!!! My first problem was that I didn't even have a window specified! It all works great now.You rock RoboWizard!
            • 3. Re: Opening CHM with HTMLHelp from MFC
              RoboWizard Level 4
              LOL, you must be looking over my shoulder when I drive! Cause I Roll too.

              (I'm an old Rock & Roll fan)

              Seriously, I'm glad to have been of any assistance. But keep in mind that we work hard to keep the forums a nice, friendly, and most of all helpful! place to visit. There are a good many of us here that are that way.

              Cheers all! Rick
              • 4. Re: Opening CHM with HTMLHelp from MFC
                RoboWizard Level 4
                LOL, you must be looking over my shoulder when I drive! Cause I Roll too.

                (I'm an old Rock & Roll fan)

                Seriously, I'm glad to have been of any assistance. But keep in mind that we work hard to keep the forums a nice, friendly, and most of all helpful! place to visit. There are a good many of us here that are that way.

                Cheers all! Rick
                • 5. Re: Opening CHM with HTMLHelp from MFC
                  SFarmer92
                  I have a similar problem and sorry, I didn't understand what you told LarEpp. I can create and view the Microsoft HTML Help file when I save it on my local machine. But when I save it to the server so that it can be called by the powerbuilder program it accompanies, and open it to view the help, I get the following: "Internet Explorer was unable to link to the web page you requested. The page might be temporarily unavailable." I can see the topic list, but clicking on a help topic just shows a blank in the right pane.
                  When you say expand the windows folder, where do you do that? Maybe that pertains to the MFC application LarEpp uses. Thanks
                  • 6. Re: Opening CHM with HTMLHelp from MFC
                    Captiv8r Adobe Community Professional & MVP
                    Hi SFarmer92 and welcome to our community

                    What I advised LarEpp was related to synchronizing the Table of Contents with the displayed topic. Your issue is totally different. From what I see, you are trying to make a .CHM file work in a LAN environment. Click here to read all about this pesky issue

                    Cheers... Rick