13 Replies Latest reply on Oct 7, 2006 4:41 PM by Newsgroup_User

    Relative links don't work in Fireworks 8?

    brianwinter
      I'm using an HTML front end for navigation of files on a CD.
      I set up a menu with rollovers and links in Fireworks MX2004. When I try to do the same thing in Fireworks 8, the rollovers work but the links don't. In Fireworks 8 I tried pointing the links to external websites and they start working fine. Whenever I try a relative link to a file in the same directory on my hard drive, though, it stops working. There's no error message or anything, no action at all when I click the button.
      Why is this very basic thing suddenly broken in v8 when it worked fine in MX2004? What the **** did they do to it?
        • 1. Re: Relative links don't work in Fireworks 8?
          TezS56 Level 1
          I have got the same problem. What is the anser?
          • 2. Re: Relative links don't work in Fireworks 8?
            Level 7
            Make your links root relative. Or don't use FW to write your HTML at all.

            --
            Murray --- ICQ 71997575
            Adobe Community Expert
            (If you *MUST* email me, don't LAUGH when you do so!)
            ==================
            http://www.dreamweavermx-templates.com - Template Triage!
            http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
            http://www.dwfaq.com - DW FAQs, Tutorials & Resources
            http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
            ==================


            "TezS56" <webforumsuser@macromedia.com> wrote in message
            news:eg0kva$igk$1@forums.macromedia.com...
            >I have got the same problem. What is the anser?


            • 3. Re: Relative links don't work in Fireworks 8?
              brianwinter Level 1
              What do you mean "root relative"?
              • 4. Re: Relative links don't work in Fireworks 8?
                Level 7
                I mean make the link relative to the root of the site -

                <img src="/whatever/whatever.jpg"

                Such links will work no matter where the page containing that link is
                located within the site.

                --
                Murray --- ICQ 71997575
                Adobe Community Expert
                (If you *MUST* email me, don't LAUGH when you do so!)
                ==================
                http://www.dreamweavermx-templates.com - Template Triage!
                http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
                ==================


                "brianwinter" <webforumsuser@macromedia.com> wrote in message
                news:eg133o$6o6$1@forums.macromedia.com...
                > What do you mean "root relative"?


                • 5. Re: Relative links don't work in Fireworks 8?
                  TezS56 Level 1
                  Are you saying not to use the ../
                  This works is FWX MX and is a standard HTML path name.
                  Something is not right here. I have created a whole web site using FWX 8. Have I got to go back to FWX MX to create the links? Why did I upgrade?
                  • 6. Re: Relative links don't work in Fireworks 8?
                    Level 7
                    When you create a link, you have to option to make it document relative,
                    e.g.,

                    <img src="../whatever/whatever.gif"

                    (This means to start at the location of the current file, go up one
                    directory level, look for a folder named "whatever", go into that folder and
                    find a file called "whatever.gif" - it depends on the current file's
                    location. This same link may not work for any other file in any other
                    location in your site.)

                    or root relative, e.g.,

                    <img src="/whatever/whatever.gif"

                    (This means to start at the root of the site, find a folder called
                    "whatever" and use the "whatever.gif" file within. This same link will work
                    for all files in all locations of your site, since it doesn't depend on the
                    location of the containing file, which can change, but rather on the
                    location of the root of the site, which never changes.)

                    If you would have created your links with root relative links rather than
                    document relative ones, they would work now.

                    This is not related to the update you did. It's related to the specific way
                    in which you are now using the files.

                    And, for what it's worth, most people here, and elsewhere will tell you that
                    the FW menus are much much much more trouble than they are worth. They were
                    slightly improved in FW8 compared to earlier but they still are a flawed
                    implementation....

                    --
                    Murray --- ICQ 71997575
                    Adobe Community Expert
                    (If you *MUST* email me, don't LAUGH when you do so!)
                    ==================
                    http://www.dreamweavermx-templates.com - Template Triage!
                    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                    http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
                    ==================


                    "TezS56" <webforumsuser@macromedia.com> wrote in message
                    news:eg1ker$q66$1@forums.macromedia.com...
                    > Are you saying not to use the ../
                    > This works is FWX MX and is a standard HTML path name.
                    > Something is not right here. I have created a whole web site using FWX 8.
                    > Have
                    > I got to go back to FWX MX to create the links? Why did I upgrade?
                    >


                    • 7. Re: Relative links don't work in Fireworks 8?
                      TezS56 Level 1
                      Been there done that, still not working. As a work around I set up my buttons in FW MX expoted them from there and then linked the slices (buttons) in Dreamweaver. That method works fine. I'm very disapointed with FW8, I feel I have been cheated out of the price of the software. You live a learn :-( but thanks for your help it was most appreciated.
                      • 8. Re: Relative links don't work in Fireworks 8?
                        Level 7
                        The real answer is not to use FW for your HTML at all.

                        Show me your page, please.

                        --
                        Murray --- ICQ 71997575
                        Adobe Community Expert
                        (If you *MUST* email me, don't LAUGH when you do so!)
                        ==================
                        http://www.dreamweavermx-templates.com - Template Triage!
                        http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                        http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                        http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
                        ==================


                        "TezS56" <webforumsuser@macromedia.com> wrote in message
                        news:eg3v09$mro$1@forums.macromedia.com...
                        > Been there done that, still not working. As a work around I set up my
                        > buttons
                        > in FW MX expoted them from there and then linked the slices (buttons) in
                        > Dreamweaver. That method works fine. I'm very disapointed with FW8, I feel
                        > I
                        > have been cheated out of the price of the software. You live a learn :-(
                        > but
                        > thanks for your help it was most appreciated.
                        >


                        • 9. Re: Relative links don't work in Fireworks 8?
                          Level 7
                          TezS56 wrote:
                          > Been there done that, still not working. As a work around I set up my buttons
                          > in FW MX expoted them from there and then linked the slices (buttons) in
                          > Dreamweaver. That method works fine. I'm very disapointed with FW8, I feel I
                          > have been cheated out of the price of the software. You live a learn :-( but
                          > thanks for your help it was most appreciated.
                          >

                          I've gotten much more consistent and easier to maintain results using
                          Pop Menu Magic from Project 7 which is an extension for Dreamweaver.
                          Every year I need to create a CD of speaker support files for a
                          conference client. The Pop Menu Magic system was worth every penny in
                          that I can quickly build and edit these menus as new material gets added.

                          While the Pop Up menu in FW is a tool, it is by no means the BEST or
                          only tool in an impressive web graphics program. If this is the only
                          feature you use, I agree, your money would be better spent elsewhere.

                          On the other hand, if one uses the program and all its other features
                          regularly, one would be hard pressed to find a better app for creating
                          and optimizing web and screen graphics.

                          --
                          Jim Babbage - .:Community MX:. & .:Adobe Community Expert:.
                          Extending Knowledge, Daily
                          http://www.communityMX.com/
                          CommunityMX - Free Resources:
                          http://www.communitymx.com/free.cfm
                          ---
                          .:Adobe Community Expert for Fireworks:.
                          news://forums.macromedia.com/macromedia.fireworks
                          news://forums.macromedia.com/macromedia.dreamweaver
                          • 10. Re: Relative links don't work in Fireworks 8?
                            TezS56 Level 1
                            The page I am working on can be found at :
                            http://reallygoodco.com/ODwebsiteTest/04_04ld_menu.htm

                            This is the page that I have taken into FW MX and exported to Dreamweaver to add the links. I have more links to add and quite a few other pages to produce. Any help I can get from you in speeding this production, I assure you, will be greately appreciated.
                            • 11. Re: Relative links don't work in Fireworks 8?
                              Level 7
                              First thing to do is to delete this from the top of that file -

                              <?xml version="1.0" encoding="utf-8"?>

                              It's optional, and in fact, having it will put IE into quirks mode, which
                              you do not want.

                              Second, best practice methods suggest not to use spaces in your
                              file/pathnames -

                              <a href="Change MHS April 2004.pps"

                              and I think you should follow that suggestion here.

                              Also, linking directly to a pps file will not work on the web.

                              Third, I'm not sure that these pages/files are anywhere on your server - did
                              you upload them?

                              For example - this file,

                              web_pictures/index.htm

                              is not here -

                              http://reallygoodco.com/web_pictures/index.htm

                              and it's not here -

                              http://reallygoodco.com/ODwebsiteTest/web_pictures/index.htm

                              So where *should* that link be pointing?

                              --
                              Murray --- ICQ 71997575
                              Adobe Community Expert
                              (If you *MUST* email me, don't LAUGH when you do so!)
                              ==================
                              http://www.dreamweavermx-templates.com - Template Triage!
                              http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                              http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                              http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
                              ==================


                              "TezS56" <webforumsuser@macromedia.com> wrote in message
                              news:eg57vm$6m8$1@forums.macromedia.com...
                              > The page I am working on can be found at :
                              > http://reallygoodco.com/ODwebsiteTest/04_04ld_menu.htm
                              >
                              > This is the page that I have taken into FW MX and exported to Dreamweaver
                              > to
                              > add the links. I have more links to add and quite a few other pages to
                              > produce.
                              > Any help I can get from you in speeding this production, I assure you,
                              > will be
                              > greately appreciated.
                              >


                              • 12. Re: Relative links don't work in Fireworks 8?
                                TezS56 Level 1
                                thanks for taking the time to look at this, I really do appreciate your time. I will certainly delete the <?xml version="1.0" encoding="utf-8"?> statement but this is what is produced by FW. If this is incorrect don't you think that it should not be generated by FW?
                                The other stuff you mentioned is because I did not up load the rest of the files only that page. I have not had a problem linking to a PPS files in the past but I will keep my eyes open for any problems in that area.
                                As an update for you, my work around of creating the buttons in FW MX, exporting the HTML and then adding the links to the slices in Dreamweaver 8 is working fine, so I am happy with the outcome although not happy with FW8. Don't get me wrong, I love FW I just get so frustrated when they say you can do "this" but in reality you have to jump through hoops to make it work. They don't tell you this when they are charging and arm and a leg for the program. I design and develop on my own and have to rely on people like yourself to help me. So thanks to you and the others here who are willing to spare their time to help me.
                                • 13. Re: Relative links don't work in Fireworks 8?
                                  Level 7
                                  > If this is incorrect don't you think that it should not be generated by
                                  > FW?

                                  Yes. But then you shouldn't be using a graphics program to write your HTML
                                  anyhow.

                                  > I have not had a problem linking to a PPS files

                                  What about the person who doesn't have PowerPoint installed?

                                  > "this" but in reality you have to jump through hoops to make it work.

                                  This is not the reality. The reality is that if you are going to use FW to
                                  write your HTML, you have to already know enough HTML to be able to know how
                                  to tell it to write it so that it doesn't cause you problems. See the irony
                                  there? Knowing HTML is a good thing, however, and if you are serious about
                                  doing this, you will have to learn it.

                                  > don't tell you this when they are charging and arm and a leg for the
                                  > program

                                  <shrug>I make it all back on the first job.

                                  --
                                  Murray --- ICQ 71997575
                                  Adobe Community Expert
                                  (If you *MUST* email me, don't LAUGH when you do so!)
                                  ==================
                                  http://www.dreamweavermx-templates.com - Template Triage!
                                  http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                                  http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                                  http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
                                  ==================


                                  "TezS56" <webforumsuser@macromedia.com> wrote in message
                                  news:eg947g$m2p$1@forums.macromedia.com...
                                  > thanks for taking the time to look at this, I really do appreciate your
                                  > time. I
                                  > will certainly delete the <?xml version="1.0" encoding="utf-8"?> statement
                                  > but
                                  > this is what is produced by FW. If this is incorrect don't you think that
                                  > it
                                  > should not be generated by FW?
                                  > The other stuff you mentioned is because I did not up load the rest of the
                                  > files only that page. I have not had a problem linking to a PPS files in
                                  > the
                                  > past but I will keep my eyes open for any problems in that area.
                                  > As an update for you, my work around of creating the buttons in FW MX,
                                  > exporting the HTML and then adding the links to the slices in Dreamweaver
                                  > 8 is
                                  > working fine, so I am happy with the outcome although not happy with FW8.
                                  > Don't
                                  > get me wrong, I love FW I just get so frustrated when they say you can do
                                  > "this" but in reality you have to jump through hoops to make it work. They
                                  > don't tell you this when they are charging and arm and a leg for the
                                  > program. I
                                  > design and develop on my own and have to rely on people like yourself to
                                  > help
                                  > me. So thanks to you and the others here who are willing to spare their
                                  > time to
                                  > help me.
                                  >
                                  >