4 Replies Latest reply on Feb 12, 2008 5:18 AM by jdeline

    Formatting in Plain Text - CFMAIL

      I have a client who has given me a task.. and I can't find the answer.

      Their site has a form that uses CFMAIL to send an email to their admin email address.

      When the email arrives, it shows up in Times New Roman font, which is fine.
      However, when they hit the 'Reply' button in their mail client, they have their system set up to use Microsoft Word to do the editing.
      When the message opens in word, it is no longer in Times New Roman. It is in Arial. They dont want Arial.

      I changed the CFMAIL tag to send in HTML, and just used regular font tags to format the message to Times New Roman. That caused the email to be delivered in Times New Roman, which was fine.
      When they clicked on 'Reply', Microsoft Word opened and the text was in Times New Roman, which was fine.
      However, along with all the text being displayed in Times New Roman, all of the tags in the email, including font tags and line breaks were also displayed.

      Right now their only option is to have the email sent in Plain Text and when Microsoft Word opens up with the message in Arial, they just select it all and switch it to Times New Roman.

      To me, that's not a big issue. Select All, Change Font, continue what you were doing.
      But this client is a stickler for details and has been on me to find an answer to this for weeks now.

      I told them that if they just used Outlook (their mail client) to do the replies, this would no longer be an issue - but they are dead set on using MS Word (dont know why).

      So, the question is, is there some way to force the font to Times New Roman when they open up the email in Word?

      I dont think there is (I cant find one), but this client is blaming the CFMAIL tag for the problem, and I think it's an MS Word issue.

      Any ideas?

        • 1. Re: Formatting in Plain Text - CFMAIL
          Level 7
          eTeli.com wrote:
          > Any ideas?
          > Kudos,
          > eTeli

          Send them an email from some UNIX system using an ancient mail program
          such as ELM or PINE and have them see that this is going to happen to
          any email sent from any system. If you don't have access to an old ELM
          or PINE - Yahoo, Hotmail or Google would probably also work if in a
          somewhat less dramatic fashion.

          <CFMAIL...>, or any mail tool, has nothing to say about what happens to
          the message once it has arrived on the client system. If they start
          changing it, it is going to get changed. And if the tools the client
          uses (i.e. Outlook and MS Word) does that change automatically against
          the users desires, <CFMAIL...>, or any mail tool, is not going to be
          able to help them.

          Of course I suspect somewhere buried in MS Word is a setting or option
          on what font to have imported plain text displayed in.
          • 2. Re: Formatting in Plain Text - CFMAIL
            eTeli.com Level 1
            Thanks for that.

            It is what I figured all along. We searched around in Word to see if there was some kind of place where we could set the default imported text font and size, but didn't find anything.

            Hopefully they'll just get used to the idea that mixing Word with email can't always have the results they want.

            • 3. Re: Formatting in Plain Text - CFMAIL
              In Microsoft Word, the default font is set in the Normal.Dot template. To find out where it is located, click File | New, select "New from Template', right click on the "Blank Document" template and look at the properties. Open this template AS A TEMPLATE file, change the font, and save. My guess is that should solve your problem.
              • 4. Re: Formatting in Plain Text - CFMAIL
                jdeline Level 1
                BobDean is correct. I believe you can also set it using the Format > Font from the menu bar. Select the font you want and click "Default" in the lower left corner.