6 Replies Latest reply on Jun 8, 2011 5:24 AM by cagreen76

    Cron service not available error

    LoanXEngine
      A production issue appeared today at one of our customer sites.... and I am unable to login to CFadmin. I stop and restart the services, but still the same issue appears. See below.

      Anyone have any thoughts? Ideas? Has anyone ever seen this before??

      Error Occurred While Processing Request
      The Cron service is not available.
      This exception is usually caused by service startup failure. Please check your server configuration.

      The error occurred in Application.cfm: line 78

      -1 : Unable to display error's location in a CFML template.



      --------------------------------------------------------------------------------

      Please try the following:
      Check the ColdFusion documentation to verify that you are using the correct syntax.
      Search the Knowledge Base to find a solution to your problem.


      Browser Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322)
      Remote Address 127.0.0.1
      Referrer
      Date/Time 25-Apr-06 12:57 PM

      Stack Trace (click to expand)
      at cfApplication2ecfm105811000.runPage(C:\blackstone_final\cfusion\wwwroot\CFIDE\administrat or\Application.cfm:78)


      coldfusion.server.ServiceFactory$ServiceNotAvailableException: The Cron service is not available.
      at coldfusion.server.ServiceFactory.getCronService(ServiceFactory.java:118)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at coldfusion.runtime.java.JavaProxy.invoke(JavaProxy.java:74)
      at coldfusion.runtime.CfJspPage._invoke(CfJspPage.java:1627)
      at cfApplication2ecfm105811000.runPage(C:\blackstone_final\cfusion\wwwroot\CFIDE\administrat or\Application.cfm:78)
      at coldfusion.runtime.CfJspPage.invoke(CfJspPage.java:152)
      at coldfusion.tagext.lang.IncludeTag.doStartTag(IncludeTag.java:343)
      at coldfusion.filter.CfincludeFilter.invoke(CfincludeFilter.java:65)
      at coldfusion.filter.CfincludeFilter.include(CfincludeFilter.java:33)
      at coldfusion.filter.ApplicationFilter.invoke(ApplicationFilter.java:157)
      at coldfusion.filter.RequestMonitorFilter.invoke(RequestMonitorFilter.java:51)
      at coldfusion.filter.PathFilter.invoke(PathFilter.java:86)
      at coldfusion.filter.ExceptionFilter.invoke(ExceptionFilter.java:50)
      at coldfusion.filter.BrowserDebugFilter.invoke(BrowserDebugFilter.java:52)
      at coldfusion.filter.ClientScopePersistenceFilter.invoke(ClientScopePersistenceFilter.java:2 8)
      at coldfusion.filter.BrowserFilter.invoke(BrowserFilter.java:38)
      at coldfusion.filter.GlobalsFilter.invoke(GlobalsFilter.java:38)
      at coldfusion.filter.DatasourceFilter.invoke(DatasourceFilter.java:22)
      at coldfusion.CfmServlet.service(CfmServlet.java:105)
      at coldfusion.bootstrap.BootstrapServlet.service(BootstrapServlet.java:78)
      at jrun.servlet.ServletInvoker.invoke(ServletInvoker.java:91)
      at jrun.servlet.JRunInvokerChain.invokeNext(JRunInvokerChain.java:42)
      at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequestDispatcher.java:257)
      at jrun.servlet.ServletEngineService.dispatch(ServletEngineService.java:527)
      at jrun.servlet.jrpp.JRunProxyService.invokeRunnable(JRunProxyService.java:204)
      at jrunx.scheduler.ThreadPool$DownstreamMetrics.invokeRunnable(ThreadPool.java:349)
      at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.java:457)
      at jrunx.scheduler.ThreadPool$UpstreamMetrics.invokeRunnable(ThreadPool.java:295)
      at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66)



        • 1. Re: Cron service not available error
          kaymaan
          Hi LoanXEngine,

          This issue appeared in one of our production servers today and nothing (restarting CF services & rebooting the machine) seems to fix it. Since you experienced this problem several months ago, I was wondering if you were able to fix it and how (short of uninstalling and reinstalling the CF)?

          Any help you can provide will be greatly appreciated.

          Thanks.
          • 2. Re: Cron service not available error
            kaymaan Level 1
            For the benefit of anyone else who might run into this problem, here is what I did to solve this problem on our server:

            I noticed that the cf_root\lib\neo-cron.xml file had a size of 0, so I restored it from a back-up copy. Stopped & restarted the CF service and all was well again.

            Rgds.
            • 3. Re: Cron service not available error
              LoanXEngine Level 1
              Yes,

              We figured it out as well. The neo-cron.xml file corrupted. If you use a lot of cfschedule and don't clean it out regularly.... definitely keep yourself a backup of neo-cron...
              • 4. Re: Cron service not available error
                C-Ramey
                We found a bug in the administrator that occurs when you copy and paste the scheduled task name adds characters that the administrator cannot read. If you look, I bet you'll find it as well.

                You can search your neo-cron.xml file for the following:

                • Search for the text “>'>”
                • Cut the text “<char code='09'/>”
                • Place it behind the '> Example:( ‘><char code='09'/> )
                • 5. Re: Cron service not available error
                  ftw37
                  I had the same problem. I couldn't get into the Coldfusion administrator pages, since it was complaining that "cron service is not available."

                  It turns out that my C:\CFusionMX7\lib\neo-cron.xml was corrupt.

                  I opened neo-cron.xml in Internet Explorer to find out where the corruption was.

                  There were some spurious <char code='09'/> references in some of the <var name=' '> tags.

                  In my case, here's what didn't work: <var name=' <char code='09'/> Name of Demo Scheduled Task'>

                  Note the spaces before and after the code='09' tag.

                  After, here's what did work: <var name='Name of Demo Scheduled Task'>

                  I saved the new C:\CFusionMX7\lib\neo-cron.xml file and restarted the CF MX 7 service. The Coldfusion administrator came back up and my scheduled tasks were in there.



                  • 6. Re: Cron service not available error
                    cagreen76

                    I'm receiving the exact same error as the original post. We tried every suggestion on this forum and still get the 'cron service not available' error. I've also checked and we don't have a neo-cron.xml file. We are using Coldfusion 8.

                     

                    The Cron service is not available.

                     

                    This exception is usually caused by service startup failure. Check your server configuration.

                     

                    The error occurred in Application.cfm: line 84

                    Called from Application.cfm: line 4

                    Called from Application.cfm: line 1

                    -1: Unable to display error's location in a CFML template.

                     

                     

                    Any help will be appreciated. Thanks.

                     

                    Crystal