29 Replies Latest reply on Mar 11, 2019 9:17 AM by OhTheFuture Branched to a new discussion.

    Bug: Timeline playback is extremely laggy in CC 2019

    isaacb59467666 Level 1

      I'd classify the current timeline playback implementation as very buggy in the most recent release. I'm running with up to date Nvidia drivers (with the latest version of Cuda), and in testing a project on the previous version and this version, the playback lag rendered editing in CC 2019 completely unusable.

       

      Is anyone else dealing with similar issues? I'm on a Windows PC laptop, i7-7700HQ, 32 Gigs of ram. The previous version worked perfectly for editing GH5 10-bit footage. As a test, I have the same project setup in Davinci Resolve 15, and it plays and perfectly with zero lag.

       

      Adobe, please fix the playback and Cuda acceleration problems in the latest version!

        • 1. Re: Bug: Timeline playback is extremely laggy in CC 2019
          Jim_Simon Level 9

          You are using Cineform proxies, as described below?

           

          Work offline using proxy media |

          • 2. Re: Bug: Timeline playback is extremely laggy in CC 2019
            isaacb59467666 Level 1

            I am not using proxies. I have used the proxy workflow before, but am not prepared to unnecessarily change my workflow due to a bug. I'm sticking to CC 2018 since the timeline playback works as it should.

             

            I'll give CC 2019 another try in a few months once they've worked out the bugs and fixed their Cuda support.

            • 3. Re: Bug: Timeline playback is extremely laggy in CC 2019
              jbeizer Level 1

              This is especially true when working with Dynamic Link. CC 2018 worked fine for me, with or without proxies, and now rendering out even basic Dynamic Link comps takes much longer. I'm on a 2013 Mac Pro with 24 GB of RAM, and i"m working largely with still photos and a few blended layers on top. Nothing that I've had problems with before, and yet the new update has made it excruciating to render.

              • 4. Re: Bug: Timeline playback is extremely laggy in CC 2019
                axelc6108486 Level 1

                Hey guys,

                 

                I was also experiencing stuttering in Premiere Pro CC 2019.

                I recently purchased the Atomos Ninja V, an external recorder that can record up to 4k60p 422 10-bit signal.

                I tried everything to fix the lagg and even my proxy files were lagging.

                 

                I went into sequence settings > video previews:

                There i saw that the video preview quality was set sky-high on a DNxHR RGB 444 UHD 25 / 3840x2160 format with the option

                'compositie in linear color' turned on. This was clearly the problem.

                 

                I changed the video preview settings to DNxHD LB 1920x1080 with the option 'compositie in linear color' turned off.

                Now my Premiere runs smooth like butter again.

                 

                Hopefully this helps for some people, cheers!

                5 people found this helpful
                • 5. Re: Bug: Timeline playback is extremely laggy in CC 2019
                  r_adams_chs Level 1

                  I had the same problem when updating to 2019.

                   

                  Turns out the supplied external drive (USB 3.0) I had my clips on was formatted 'ExFat'. Since moving them to a Max OS Extended drive things ran like usual again.

                  1 person found this helpful
                  • 6. Re: Bug: Timeline playback is extremely laggy in CC 2019
                    isaacb59467666 Level 1

                    The linear color check, unfortunately, does not solve my problem. In CC 2018, I have the identical project set up as a test where linear color is checked and things run flawlessly. I've tried checking and unchecking in CC 2019 without success. Playback chugs along.

                     

                    At this point, I'm waiting for the next update to see if they sort out the errors. This issue is present on both my 1060 and 1080 TI cards. So I'm pretty certain there's an issue with the Cuda implementation in 2019.

                    • 7. Re: Bug: Timeline playback is extremely laggy in CC 2019
                      chrisl82235677 Level 1

                      Experiencing exactly the same problem. Been using Premiere Pro CC 2019 since it was launched and it was working perfectly but now the timeline is running really laggy and choppy.

                       

                      I'm using my normal 4k footage and Cineform 720p proxies workflow and it's never been like this. It's almost unusable!

                       

                      I've opened the same project in Premiere Pro CC 2018 and I have no play back issues at all.

                       

                      There definitely seems to be a problem with the current version of Premiere Pro CC 2019.

                      • 8. Re: Bug: Timeline playback is extremely laggy in CC 2019
                        Brettski Level 1

                        I have the exact same problem and second your request for Adobe to fix this ASAP! I'm using Cineform proxies and they're playing back incredibly laggy on 2019, fine on 2018.

                        • 9. Re: Bug: Timeline playback is extremely laggy in CC 2019
                          Christiaan1 Level 1

                          I'm also experiencing laggy choppy video in the timeline. Even in FULL HD after the CC19 update.

                          A have a monster PC. Fastest i7 64GB mem. 1080Ti, Fast Raid 10 drives.
                          Adobe, what is wrong?

                          • 10. Re: Bug: Timeline playback is extremely laggy in CC 2019
                            Christiaan1 Level 1

                            I noticed that updating the nvidia drivers gave some performance improvements.

                            • 11. Re: Bug: Timeline playback is extremely laggy in CC 2019
                              davidb99256629 Level 1

                              Has anyone been able to find a fix for this? I'm having the same problem. Project worked fine in Premiere Pro CC 2018 but playback is extremely laggy in 2019 and I cannot work on projects. 

                              • 12. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                isaacb59467666 Level 1

                                There is no fix at the moment, not with recent Nvidia drivers or playing around with sequence settings and linear color. This program is broken at the moment and it's an absolutely embarrassing release. I'm in the middle of a couple projects but am planning on learning and switching to Davinci Resolve over the Christmas break once work quiets down.

                                 

                                I'll miss the tight integration with After Effects and the rest of the CC suite, but this program is completely unusable for professional work at the moment. And there's no acknowledgment or timetable for getting this fixed. I've used Premiere for a long time (Since Release 5.1 in 1999) and I've never seen a worse roll-out than this one.

                                • 13. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                  RESH Level 2

                                  I had some time to mess with this today because it is bugging me, too. I exported three different :30 files, a Cineform 1920x1080 10-bit YUV, a comparable DNxHD HQX 10-bit file, and a 10-bit uncompressed quicktime. I played each one of them in their own timeline in each version of Premiere (2018 and 2019) and watched the task manager for CPU/GPU usage. So, six timelines—three in each version.

                                   

                                  Both the Cineform and DNxHD start out with really high CPU usages ~20+% then settle down after about 5 seconds to something more reasonable. And it was actually higher in 2019, starting around 25-20%

                                   

                                  In 2018 they settle to about 4-6%, but it seemed that in 2019 they only lowered to 7-9% and then would occasionally creep up and down.

                                   

                                  The uncompressed started at 4% and remained the same in both programs. No initial CPU surge at all. This would explain why setting my previews to 10-bit uncompressed smoothed all my problems out for me. Problem is, they are giant and only good for short form work.

                                   

                                  GPU loads were about the same in both.

                                   

                                  The fact that 2019 started the video with a higher CPU load and never settled to the same low number may be just enough of a difference that everytime it hits a new edit it has to deal with this.

                                   

                                  I'm sure someone here will find problems with my un-scientific method, but I'm just trying to figure out why 2018 is so smooth compared to 2019 playing off the same drive with the same footage. I thought I'd explain what I did so maybe it'll lead someone to figuring this out.

                                   

                                  **EDIT. Okay one thing I did was just go find updated drivers for my ASmedia USB 3.1 chipsets. The ones that Microsoft installs are from 2016. These are from 7/2018 and WHQL certified. They made a big difference. So that has helped a lot. Wish MS and/or the manufacturers would keep these up to date. Even the motherboard manufacturer has the old ones listed.

                                  • 14. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                    Please Help Level 1

                                    Having Completely unacceptable lag issues with playback!!!!!!!!! On a Mac Pro (Late 2013) 3.5 GHz 6-Core Intel Xeon E5 64 GB 1866 MHz DDR3.

                                     

                                    I can't even get the playhead to load the frame when I move it. I hit spacebar it takes 10 seconds plus to start playing. I have tried EVERY video preview setting they have. THIS NEEDS TO GET FIXED F-ING FAST OR IT'S TIME TO MOVE ON TO AVID!

                                    • 15. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                      JimmyCrackCorn Level 1

                                      I'm on a mac pro 5.1 on Mojave 10.14.2 with 30 gig of ram, a saphire RX-580 5g video card running Pr2019.

                                      Its a complete disaster... lagging playback, or freezes while I have to wait 10 secs for the space bar to engage playback and with just a small amount of media it gets increasingly longer to save... auto save can sit there for 20 secs!  I feel like I'm editing on a 1990s piece of software.  At least in rarely crashes which is small consolation.

                                       

                                      My fix is to get thru editing is to mute the Fx while cutting.

                                       

                                      Pr 2019 is just not ready for Mojave!!!!!  So far this is the only solution... If you're on Pr 2018, I'd suggest delaying an upgrade.

                                      Adobe please work on the basics, stable platform, good code to maximize rendering and playback.  Forget 3D and VR and all

                                      your other marketing tricks because if you don't solve this soon I'm abandoning Pr for good.

                                      • 16. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                        JimmyCrackCorn Level 1

                                        I forgot to mention I'm cutting with 1080p material shot at 29.27

                                        • 17. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                          isaacb59467666 Level 1

                                          The most recent update has not fixed the laggy timeline playback issue. This is pretty bad, and it's looking pretty likely that I'll be migrating to Resolve shortly. Can't say much more than that I'm disappointed in Adobe and this latest release. It's DOA.

                                          • 18. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                            makoms Level 1

                                            Do they even bother to look at these messages to care enough to fix this?

                                             

                                            I'm 90% on the way to finishing my film and now I can't even play back the timeline sequence and pause and edit because it will take 15 seconds to load playback again.

                                             

                                            It's like hey we'll take your money and give you a horrible product. Now i'm stuck because I can't spend 8 months re-editing on a new software.

                                            • 19. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                              JimmyCrackCorn Level 1

                                              I've gone back to Sierra OS and Pr 2018 until they sort this out. I'm sorry to hear about your frustration.

                                              I wonder if its only Mac versions that are the most problematic.

                                              • 20. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                Lichtsammler Level 1

                                                Same problem. Projects getting slower and slower... A workaround for me was creating a new empty project, mark all the stuff of the laggy project and insert it into the empty one. Close the old one. - Here it works until the next day perhaps ...  then I have to do it again.

                                                • 21. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                  Todd Mobley Level 1

                                                  1/4/19 - Just upgraded to CC2019 and it is 100% WORTHLESS. Completely unusable.

                                                  • 22. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                    chrisl82235677 Level 1

                                                    I've found that randomly premiere pro loses the ability to use CUDA. If I then restart premiere it then picks up the CUDA option and then it works fine. It happens randomly though!

                                                    1 person found this helpful
                                                    • 23. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                      英司白15357125 Level 1

                                                      I also changed the exFAT to HFS + and solved the problem.
                                                      Thank you very much!

                                                      MacPro 2013

                                                      High Sierra

                                                      Premiere Pro CC 13.0.2

                                                      • 24. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                        rsli43293911 Level 1

                                                        I thought I was alone with this issue.

                                                        6 Core, 64GB RAM, 950 and 850 pro SSDs for OS, Scratch and storage. GTX 1070 and clean install

                                                         

                                                        ANY footage I put in the timeline results in a CPU spike to 100% for the first few seconds, then drops to 20-30% and dropped frames, GPU barely utilized ever except for plugins.  I'll put the playhead back to the beginning and sometimes it plays at 30% cpu, sometimes 100%.  Seems moving it to any other position almost always causes a spike. 

                                                        Proxies, various formats NOTHING works.  I dropped a 720 avi file in form years ago and it even had a little spike on playback.

                                                        Effects on/off, resolution full or 1/4.  Every post I can find including developer tweaks offer absolutely nothing.

                                                         

                                                        Despite relying heavily on AE, Premiere and Photoshop, what the hell good is it if you can't even simply playback footage in the timeline that other programs can do with 4 at time without breaking a sweat?

                                                         

                                                        Next update if nothing changes, I'm forced out.  Projects are costing me time and money.  It's going to be painful I'm sure but I'm just disgusted at their money grabbing subscription model coupled with sh1t quality control and ignoring thousands of issues people have.

                                                         

                                                        Worse yet are the paid apologists on the forums that blame everything on users adding insult to injury.

                                                        • 25. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                          blakekimmel Level 1

                                                          THIS! Fixed my problems. Was having purely miserable playback in CC2019 even after rendering, while CC2018 was playing other projects perfectly. Mine was also at 4K Animation Codec for some reason. HD DXNR fixed problem immediately.

                                                           

                                                          Unfortunately gotta change it for each sequence one at a time in the project but still, seems to fix it.

                                                          • 26. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                            paulg9854267 Level 1

                                                            This Solved it! I have system with duel processors @ 2.2 GHz with 44 Cores total and 128 GB of RAM. Shouldn't have issues right? I installed the new RTX 2080Ti. I ran into stuttering on my timeline every 5 seconds as soon as I upgraded to Pr 2019. I tried Proxies, footage conversion, yelling, and nothing fixed it. My computer at work, which is similar, a little more powerful, but has a Quadro P6000, has no issues. I was baffled till I tried switching my timeline settings finally as suggested here and it fixed the stuttering.

                                                            - I selected my timeline sequence.

                                                            - Right clicked and chose sequence settings

                                                            - Changed my Editing Mode to DNX 1080P

                                                            - Previews to DNX HQ 1080p 24

                                                            - Codec DNxHD

                                                             

                                                            My guess is the new NVIDIA RTX 2080Ti is just less stable than a Quadro P6000. Your Codec might differ based on your card, like at work my P6000 ran Pr 2019 fine with no stuttering, but play around here till you find what works.

                                                            1 person found this helpful
                                                            • 27. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                              greggyp89 Level 1

                                                              I am having the same Issue with HLG HDR 10 Bit from the GH5...

                                                              • 28. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                                Dethel Mateo Level 1

                                                                The DNxHD codec works great with my RTX2080 now, very smooth.

                                                                • 29. Re: Bug: Timeline playback is extremely laggy in CC 2019
                                                                  OhTheFuture Level 1

                                                                  ALSO, having similar issues. Spent my whole weekend trying to figure out what the problem is.

                                                                   

                                                                  Basically, Premiere runs very laggy in the timeline and will barely export anything. After eliminating certain known effects that have caused past issues(opacity, Red Giant effects, scale combined with other effects, etc...), it still wasn't up to par.

                                                                   

                                                                  I would go back to 2018 but it wont let us open a 2019 project.