4 Replies Latest reply on Nov 8, 2018 12:18 PM by smacdonald2008

    Problem with cq start up on installation of SP3 on AEM 6.3

    sai111 Level 1

      Recently we installed SP3 on AEM 6.3 after installation it's all working and restart also worked good...but when we do deployment in Higher environment after installation of sp3 it is getting failed and start up is not happening after that , as we are seeing bundle errors as below.What could be the reason can someone help please...

       

      *ERROR* [FelixStartLevel] ERROR: Bundle '147' Error starting launchpad:resources/install/30/org.apache.sling.startupfilter.disabler-0.0.1-Rev1758544.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.startupfilter.disabler [147](R 147.0): missing requirement [org.apache.sling.startupfilter.disabler [147](R 147.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)) ) [caused by: Unable to resolve org.apache.sling.startupfilter [53](R 53.0): missing requirement [org.apache.sling.startupfilter [53](R 53.0)] osgi.implementation; (&(osgi.implementation=osgi.http)(version=1.0)) [caused by: Unable to resolve org.apache.felix.http.jetty [40](R 40.1): missing requirement [org.apache.felix.http.jetty [40](R 40.1)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.commons.logservice [11](R 11.0): missing requirement [org.apache.sling.commons.logservice [11](R11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.0): missing requirement [slf4j.api [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]]]Unresolved requirements: [[org.apache.sling.startupfilter.disabler [147](R 147.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)) )])
      org.osgi.framework.BundleException: Unable to resolve org.apache.sling.startupfilter.disabler [147](R 147.0): missing requirement [org.apache.sling.startupfilter.disabler [147](R 147.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)) ) [caused by: Unable to resolve org.apache.sling.startupfilter [53](R 53.0): missing requirement [org.apache.sling.startupfilter [53](R 53.0)] osgi.implementation; (&(osgi.implementation=osgi.http)(version=1.0)) [caused by: Unable to resolve org.apache.felix.http.jetty [40](R 40.1): missing requirement [org.apache.felix.http.jetty [40](R 40.1)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.commons.logservice [11](R 11.0): missing requirement [org.apache.sling.commons.logservice [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.0): missing requirement [slf4j.api [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]]] Unresolved requirements: [[org.apache.sling.startupfilter.disabler [147](R 147.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)) )]
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
      at java.lang.Thread.run(Thread.java:748)
      07.11.2018 11:26:26.863 *INFO * [main] Startup completed