4 Replies Latest reply on Nov 15, 2018 2:20 PM by davidg36166309

    Lightroom Pano and HDR Merge Problem

    larrym63998023 Level 1

      My Lightroom HDR and PANO merges stall with unresponsive program for 10, 20 minutes or more, if they complete at all. My feeling is that this problem started around 3-4 months ago and has if anything been getting worse in the last 1-2 months.

       

      2015 iMac, 16GB ram, running iOS 10.14 (problem predates Mojave)

      Lightroom CC 5.7.1

       

      With my system the previews take a while to execute; when I initiate the merge the Create GDR slicer completes about 4/5 reasonably fast but after that it just sits.

       

      Possible issue: If the merge does complete I get a warning box with something like 'EXIF cannot be written to the merged file.' When I click on the skip button, the merge operation finishes immediately and whenever I've checked the merged photo EXIF information looks fine.   (This warning box from memory since I have not been able to complete a Lightroom merge this week.) It's almost like Lightroom is hanging up with the EXIF step.

       

      Another possibility: I use an external NAS server to store my photo library. The connection to this server slows down Lightroom overall, but most of my editing response is acceptable. But maybe the merge operations have difficulty to read or write something from the server. Maybe I should dump the idea of using NAS as a server and just go back to using an attached hard drive.

       

      In general Lightroom merges most of my photos pretty well, even including my Mavic spherical panoramas (34 photo merge) but I've started using Hugin more for the increased merging versatility.

        • 1. Re: Lightroom Pano and HDR Merge Problem
          davidg36166309 Level 4

          Are you using smart previews?

           

          Oh, and your catalog, not the images, but the catalog. It is not on the NAS is it?

           

          Not sure if Merge Photo works using smart previews, like most of the remainder of LR will.

          • 2. Re: Lightroom Pano and HDR Merge Problem
            larrym63998023 Level 1

            Don't think I am using smart previews. (and when I grab a photo from the library it takes a while to load it from NAS - but as I mentioned it's a tolerable time)

             

            Only images are on the NAS, catalog is on the iMac

             

            I just did a check.

             

            With the NAS setup, the merge operation actually did create a proper merge dng file in the NAS directory within a few minutes (and it looks like all of the exif data attached to it is correct). The merge operation then stalled (beach ball) for the next hour and a half and never completed.

             

            I moved the pictures to a test directory on the computer and the merge completed right away.

             

            So the problem seems to be not with creating the merged photograph but with setting up the catalog (or writing exif) for the new picture - where the picture file is located in the NAS directory and the catalog information is in the iMac directory. The thing is that in the past it somehow worked most of the time.

             

            When I set up this NAS system about six months ago I could not find any references to anyone using is as a server. It seemed most people kept their photo files on their computer or on an attached hard disk, and only used the NAS for periodic backup. I thought it would be fun to see if I could actually use the NAS as a server and this has mostly worked although it is slower. It helped a lot when I added a direct ethernet connection from NAS to the computer (about 10 times faster than using a wireless interconnection).

            • 3. Re: Lightroom Pano and HDR Merge Problem
              larrym63998023 Level 1

              Whoops, I'm actually with Lightroom 6.14

              • 4. Re: Lightroom Pano and HDR Merge Problem
                davidg36166309 Level 4

                Ah, well, the v6.14 eliminates using smart previews, .