14 Replies Latest reply on Nov 28, 2018 10:34 AM by JimHess

    Future Lightroom 6 Compatibility with Mac OS X Mohave

    wlotus Level 1

      Lr 6.14 just gave me a pop up saying it will not be compatible with future versions of Mac OS X. (I am currently running Mohave 10.14.1.) I paid for Lr6 and expect to be able to continue using it. When will an update be available?