1 Reply Latest reply on Feb 6, 2009 11:28 AM by SN24

    .Net Integration Problem

    machu1
      I'm having a problem integrating .NET on the Windows 2003 Server with CF 8 (8,0,1,195765). As a test I tried two well known .NET examples:

      From Ben Forta:
      <cfobject type=".NET" name="sidiClass" class="System.IO.DriveInfo">

      and from tutorial11.learncf.com:
      <cfobject type="dotnet" name="test" class="CfSample" assembly="C:\ColdFusion8\wwwroot\av\CfSample.dll"> (assembly argument pointing to the correct path)

      Both of the above examples work OK on my two dev servers: XP+CF8 and Vista+CF8.

      The production server throws the following: Class CfSample not found in the specified assembly list (Class System.IO.DriveInfo not found in the specified assembly list. - for Ben Forta's example).

      If I stop the ColdFusion 8 .NET service, I'm getting the same error....


      Here is what I installed:

      1. .NET Framework 3.5
      2. CF801-DotNetIntegration

      Rebooted.
      ColdFusion 8 .NET service running.


      Under jnbridge folder, file 'Adobe_ColdFusion_8_.NET_Integration_Services_InstallLog.log' indicates that all inastallation steps were SUCCESSFUL.


      I also checked the neo-dotnet.xml, and all seems to be OK:
      <?xml version="1.0" encoding="UTF-8"?>
      <wddxPacket version="1.0">
      <header/>
      <data>
      <struct type="coldfusion.server.ConfigMap">
      <var name="port">
      <string>6085</string>
      </var>
      <var name="protocol">
      <string>tcp</string>
      </var>
      <var name="install_dir">
      <string>C:\ColdFusion8\jnbridge</string>
      </var>
      </struct>
      </data>
      </wddxPacket>


      I changed both services: ColdFusion 8 Application server and ColdFusion 8 .NET to log on as administrator but this has not helped either.

      I'm out of options now...