1 Reply Latest reply on Mar 24, 2008 7:36 AM by Newsgroup_User

    Can not install Bud Api Xtra on Mac Os X 1.4.x

    Level 7
      Hi

      I can not install Bud Api Xtra on Max Os X 1.4.10
      What I do:
      1) downloaded version 1.7.9 (file BuddyAPI_Mac_1.79.zip) from
      http://www.mods.com.au/budapi/download.htm
      2) extracted downloaded Zip (and found there 2 folders: "__MACOSX" and
      "Buddy API 1.79")
      3) Read docs, found there following instructions

      Xtra installation - Macintosh
      The Xtra version can be used with Director 5 and later and Authorware 4 and
      later. Buddy API can only be used in PPC Macintoshs. The Classic Xtra works
      under OS 8 and 9, either natively or under OSX. The OSX version will only
      work on OSX. For Director MX and later, place the OSX xtra (file Buddy API
      OSX Xtra) into the Director Xtras folder.
      4) Put files "Buddy API OSX Xtra" and "baWindows OSX Xtra" from folder
      "Buddy API 1.79\OSX\" of downloaded zip file into Xtras folder of Director
      installation
      5) Restarted Director

      Result: no Budapi xtra is detected (tested with showXlib, checked also the
      list of Xtras in scriptwindow)

      What did I wrong? Have I chosen the wrong files(folder) ( the icon of copied
      files in xtras folder is not usual Xtra Icon, both copied files are
      described as Unix executable files )

      Any help will be appreciated

      Game_dev



        • 1. Re: Can not install Bud Api Xtra on Mac Os X 1.4.x
          Level 7
          the problem is solved
          The problem was i've unzipped zip-file under windows and then copied files
          to mac

          "game_dev" <jorg.mann@gmx.de> wrote in message
          news:fs89ar$hsn$1@forums.macromedia.com...
          > Hi
          >
          > I can not install Bud Api Xtra on Max Os X 1.4.10
          > What I do:
          > 1) downloaded version 1.7.9 (file BuddyAPI_Mac_1.79.zip) from
          > http://www.mods.com.au/budapi/download.htm
          > 2) extracted downloaded Zip (and found there 2 folders: "__MACOSX" and
          > "Buddy API 1.79")
          > 3) Read docs, found there following instructions
          >
          > Xtra installation - Macintosh
          > The Xtra version can be used with Director 5 and later and Authorware 4
          > and later. Buddy API can only be used in PPC Macintoshs. The Classic Xtra
          > works under OS 8 and 9, either natively or under OSX. The OSX version
          > will only work on OSX. For Director MX and later, place the OSX xtra (file
          > Buddy API OSX Xtra) into the Director Xtras folder.
          > 4) Put files "Buddy API OSX Xtra" and "baWindows OSX Xtra" from folder
          > "Buddy API 1.79\OSX\" of downloaded zip file into Xtras folder of Director
          > installation
          > 5) Restarted Director
          >
          > Result: no Budapi xtra is detected (tested with showXlib, checked also the
          > list of Xtras in scriptwindow)
          >
          > What did I wrong? Have I chosen the wrong files(folder) ( the icon of
          > copied files in xtras folder is not usual Xtra Icon, both copied files are
          > described as Unix executable files )
          >
          > Any help will be appreciated
          >
          > Game_dev
          >
          >
          >