2 Replies Latest reply on Dec 4, 2018 4:56 PM by normshea

    Flash Player initiating repeated updates

    normshea

      I'm using a MacBook Pro (Retina, 13-inch, Early 2015) running Mac OS Mojave 10.14.1. From System Preferences it shows I'm running Adobe plug-ins

      NPAPI Plug-in version 31.0.0.153

      PPAPI Plug-in version 31.0.0.122

       

      I have run the latest Adobe update request but keep getting the same request over and over.  I have restarted the browser and restarted the computer.  Is anyone else experiencing this issue?  Is there any way for me to get it to stop?

        • 1. Re: Flash Player initiating repeated updates
          maria__ Adobe Employee

          We've recently identified a bug with the update URL erroneously redirecting, depending on the default browser, on macOS 10.14, resulting in the incorrect plugin downloading.  This could be what you are experiencing.  For a work-around until the bug is fixed, see the 'correct response' at Re: No PPAPI Update for 31.0.0.148

           

          To avoid the constant notifications, and have Flash Player update all plugin types on the system, silently in the background, within 24 hours of a new version being available, opt into Background Updates (update option = Allow Adobe to install updates).

           

          Background Updates are the preferred method as they update all player types on the system within 24 hours, whereas Notification Update can take up to 7 days to notify the user that an update is available, and it only updates one player type at a time (the one that made the request).   Due to this, if there is more than one player type installed, the user experiences multiple Update Notifications.

           

           

          This is the similar update behaviour that browser vendors like Chrome and Firefox use - they update silently in the background with no user intervention.

          • 2. Re: Flash Player initiating repeated updates
            normshea Level 1

            maria__,

            Thanks for the quick reply.  I'm glad to hear you are aware of the issue and are working on it.  I'll just switch from "Notify me" to "Never check" for the time being until things get sorted out.