3 Replies Latest reply on Dec 6, 2018 9:25 PM by WobertC

    Metadata not saving

    LovelyValentine

      I have checked the "automatically write changes to XMP" on my mac and also manually clicked "save metadata" before transferring the hard drive from one computer to another. When I went to import, none of my edits were saved! I have no clue why it's not saving properly but I really need to be able to work on this project from two locations. Anyone know how to solve this?

        • 1. Re: Metadata not saving
          WobertC Adobe Community Professional

          LovelyValentine  wrote

           

          I have checked the "automatically write changes to XMP" on my mac and also manually clicked "save metadata" before transferring the hard drive from one computer to another. When I went to import, none of my edits were saved! I have no clue why it's not saving properly but I really need to be able to work on this project from two locations. Anyone know how to solve this?

          If you are transferring the hard drive, why not have your Catalog on this drive with the original photo files?

          Then you can open the Catalog on either computer with 'everything'- full edit history, etc. and only one Import of photos to be done.

           

          "none of my edits were saved"-  The [Automatically write...] option in not always immediate. ie, Lightroom might delay writing to XMP until an idle time. If the drive were disconnected early, the writes may not have happened.

          Are you seeing the sidecar XMP files created with the raw files? And XMP only shows the last edited state of a photo when the XMP was created- no history, etc.

          • 2. Re: Metadata not saving
            LovelyValentine Level 1

            I have been editing this project over a period of a few days so I don't think lightroom would be that slow in writing the XMP data. Your way is a workaround but I am working on a network of many computers and multiple people accessing the same project so I would really prefer that the XMP data be saved automatically. I see the sidecar files but they haven't been updated since I originally made selections in photo mechanic weeks ago.

            • 3. Re: Metadata not saving
              WobertC Adobe Community Professional

              LovelyValentine  wrote

               

              ...a network of many computers and multiple people accessing the same project ...

              Well this another 'ball game' entirely!

              Lightroom was never designed to be a 'multi user' program, so you are trying to circumvent its basic functions.

               

              "Many computers" - Does this mean that Lightroom is installed on many computers?

              "multiple people" - Does this mean that each person is operating their own individual Catalog?

              "the same project" - Does this mean that the original images are all located on one 'central' network server accessed by all computers?

               

              I do not have experience with NAS so I might leave your question to be answered by others.

               

              I would have asked-

              Are you selecting all files before [Ctrl+S] saving metadata to files?

              Are you 'Reading' metadata from files on 'other' computer, with [Read metadata from file] ,  or Importing to another Catalog?