12 Replies Latest reply on Jan 31, 2008 9:40 AM by Ben Minson

    Unable to Import

    PapaMichael
      I've been developing a webhelp project for months, using a full-fat version of RH7. Despite happily complying previously, today RH refuses to import any files into my project. Right-click Import and File-Import-anything results in a brief cursur hour-glass then the application's stubborn refusal to respond to any mouse-click, key-stroke, soothing word or shouted expletive. Task Manager says RH is running normally but the only way I can get it to acknowledge me is to hit Escape. It then sits there smugly as if nothing happened. I've tried leaving the room to make a cup of tea, in case it needs some quiet time to collect its thoughts, but to no avail. I've even dusted off the disk and run the Repair procedure (does that ever do anything?). No change. What's going on? Have I done something to offend my RoboHelp?
        • 1. Re: Unable to Import
          RoboColum(n) Level 5
          LOL PapaMichael. RH "collecting its thoughts" sounds scary to me! Is your project on a network drive? If so, move it off and try again. If it isn't, what type of files are you importing? Does the same happen if you import a single file? What happens if you try to import one of the said files into a new project?
          • 2. Re: Unable to Import
            deepest
            Thanks for getting back to me Colum. You have to laugh sometimes, don't you. Otherwise, madness ain't far away...

            The project is on a network drive BUT I have just created a brand new project in the special My RoboHelp Projects folder in My Documents - still the same RH recalcitrance on requesting an import.

            I'm primarily attempting to import HTML files or Word docs but the problem occurs with any type of file (but not Skins, curiously). I did, however, create a New Project by importing a Word doc. That worked fine.
            • 3. Re: Unable to Import
              Papa_Michael
              P.S. I seem to have three different acounts on this forum. Not quite sure how that happened. PM.
              • 4. Re: Unable to Import
                RoboColum(n) Level 5
                The reason I asked about the network drive is that RH uses underlying MS Access technology which does not like to be placed on a network drive and can cause all sorts of untold problems until you move the project. Beware that your My Documents folder may be on a network drive if you IT people have set it up that way. I always have my source in a folder off the C drive e.g. (c:\rhsource\projectname).
                • 5. Re: Unable to Import
                  PapaMichael Level 1
                  Yeah, I'm aware of RH's uneasiness with network drives - a right pain in the derrière when it comes to corporate backup, storage policies etc. And RH7 seems to have forgotten how to publish to a network location.

                  I'm certain my My Documents in on C: but, to be absolutely conclusive, I've created another project in c:\rhsource\test as you suggest. No difference.
                  • 6. Re: Unable to Import
                    PapaMichael Level 1
                    I've just notice that the same thing happens when attempt the following commands on the File menu: Open, Load Environment and Save Environment. The other commands work fine. This is getting wierd. Are pop-up boxes being blocked?
                    • 7. Re: Unable to Import
                      Captiv8r Adobe Community Professional & MVP
                      Hi PapaMichael

                      You might check to see that some Anti-Virus application isn't conflicting. You might also check with your IT folks to see if any changes were made about the time you first began to experience the weirdness.

                      I've had that happen personally. Suddenly, after RoboHelp has worked for months on end with no issue, it starts acting weird. Upon checking with IT, at first they claimed nothing was changed. Then after more digging and asking, I heard. Ohhh, yeah. Well, we did push out a patch (or inserted some policy tweak) but that shouldn't have any effect. Uhh huh! Funny, how further tweaking finally made it work and behave again! Hmmmmm

                      Just food for thought... Rick
                      • 8. Re: Unable to Import
                        HKabaker Level 2
                        Not only the project, but the RH application must be installed on the local hard drive by the user with local administrative rights at the time of installation.

                        Among possible sources of disruption:

                        --A new version of MS Word has been installed on the local drive. You need to uninstall/reinstall RH afterward.
                        --IT has moved you to a "virtual desktop" environment, where it seems to you that you are working on your PC with your local hard drive, but in fact you are working across the network. We haven't heard of any workaround for this.

                        You mention you can't publish to a network location. I assume this means you are publishing through the Windows directory structure, such as:

                        (Networkdrive)X:\directory path\... \ .... \WebHelp\Launchfile.htm.

                        Depending on the network security setup, if the user and/or the source drive doesn't/don't have write permission on the target drive, you can't publish.

                        Harvey

                        • 9. Re: Unable to Import
                          Ben Minson
                          PM,

                          Have you been using multiple monitors lately? If so, the dialog box that you use to find the file you want to import may be appearing off your screen. Go back to using multiple monitors and see if you can find that dialog. You can also try using something like ForceWindowVisible.exe (free on the Web) to force it to show on your screen. Just a possibility,

                          Ben
                          • 10. Re: Unable to Import
                            PapaMichael Level 1
                            Give the man a cigar! I am indeed using two monitors and have been having trouble with one of them. I found out how to move dialog boxes with the keyboard and there they are - hiding off the edge of the screen!

                            Cheers Benjaminson. Mystery solved.
                            • 11. Re: Unable to Import
                              PapaMichael Level 1
                              And thanks everyone else for your suggestions.
                              • 12. Re: Unable to Import
                                Ben Minson Level 2
                                How much can I get for that cigar on ebay?