6 Replies Latest reply on Jan 29, 2008 10:58 AM by JayOyster

    X5 Crashes during HTML compile

    JayOyster
      I've searched through the forum for my problem, but although some are close, none mirrors the situation I've recently encountered. I'm working with RH X5 in a Windows 2000 environment (Windows 5.00.2195, with Service Pack 4). As of October, everything was working well. Due to the rather ancient development environment that is being used in our company, I'm restricted to generating Compiled HTML as the help output. All of this was working well through October of last year, but now RH is crashing during the compile of the help file.

      I watch the compilation process. It seems to be generating all of the content and support files. I end up with a '!chm_tmp_folder_0' file that appears to contain everything I will need in the .chm file. But about 30 to 40 seconds after it completes the 'ehlpdhtm.js' step in the generation process, it has started into 'Processing keywords...', the generation dialog box just disappears, RH doesn't refresh, and it then closes without comment after another few seconds. I end up with the aforementioned tmp folder, and a .chm file that seems to be about the right size, but when I try to open it, I get a 'The page cannot be displayed' message.

      I've moved the project folder to a folder with a short file name just off the root of the hard drive and tried to run it again. Same problem. I updated RH to version X5.0.2 (I had been at X5.0.1) . . .same problem. I verified that Comcat.DLL was version 4.71 or higher, as suggested in tech note rb_10293, verified all url's had the proper slashes for web addresses, verified I had a proper default topic and window, then I tried the trick of deleting the .xpj file and opening the project from the .hhp file. It's still crashing when I try to generate the help system as Compiled HTML, in exactly the same place each time. (Oh, and to multiply the frustration: WebHelp Pro, FlashHelp, and Printed Documentation outputs all generate successfully.)

      Any ideas why my project is crashing like this?
        • 1. Re: X5 Crashes during HTML compile
          RoboColum(n) Level 5
          Hi JayOyster and welcome to the RH community.
          First of all I assume you do not have any underscores or other non-alphanumeric characters in your CHM file name. The fact that everything was OK before October suggests so but just wanted to check.
          Failing that, what has changed since you last compiled? What type of content has been added/changed?
          • 2. Re: X5 Crashes during HTML compile
            MergeThis Level 4
            Your IT folks haven't set you up on some network system, like Terminal Server, have they? This doesn't seem like any kind of problem you should be experiencing when on your local machine only.

            You might even try the no-brainer fix of compiling to an entirely different folder, as a test. Can't hurt, as they say...


            Good luck,
            Leon
            • 3. X5 Crashes during HTML compile
              JayOyster Level 1
              Thanks for the warm welcome.

              The .chm file does have an underscore in the name. But I've compiled this project tens of times over the last two years with the same name. In fact, it compiled in October with the same name. I will try compiling without the underscore and see how it goes. . . nope. Robohelp bombed out again at the same point ('Processing keywords...'). Trying to open the resulting .chm file again gave me a help viewer with the message 'The page cannot be displayed' message.

              What has changed since October? Hmmm . . . well, mostly just Windows updates by the IT guys. Nothing else has broken on this machine in the last three months that I can recall. I just ran the Robohelp update yesterday, but that was after the problem had shown up.

              I had added 13 new topics and about 50 glossary entries before I tried to generate the .chm file. I hadn't added any content to the topics yet, just placeholder text. I marked all 760 topics with a Status of 'Complete'. The new topics and another 19 topics were marked as 'In Progress' since I need to make changes to those. I think I made a couple of minor modifications to the style of the TOC, but I don't know exactly what I changed there. I added a new topic Nope, no new network configuration. I'm working locally.

              I copied the project to a folder with a short name ('testhelp') on the root of the D: partition and tried generating the .chm from there . . . .same problem.

              An interesting item is that the previous .chm file placed out on the network for transfer to the development team is now giving me an error when I open it in that location. The TOC comes up, but the content pane shows ('Action canceled . Internet Explorer was unable to link to the Web page you requested. The page might be temporarily unavailable.') I had been able to open the help file in this location previously. If I copy that file to the local drive and run it, it's fine.

              I'm now going to try creating a little help project with just 1 or 2 topics in a simple directory location and see if it will generate the .chm . . .That worked. I'll try setting the TOC style to the same one I have in the real project. Again, the .chm file was generated with no problem.

              Any other ideas? I guess I could restore the project to its state before I touched it again last week and see if the help file generates. . . I'll try that next, but that's going to take a bit more effort. I'll let you all know if it works.
              Thanks for your help. If you have anything else I should try, please let me know.
              • 4. Re: X5 Crashes during HTML compile
                RoboColum(n) Level 5
                First off, CHM files won't run on a network drive. Click here for a full explanation as to why. I'd also strongly recommend you don't use underscores in the CHM file name, especially if you use merged help. have you tried created a new Microsoft HTML Help SSL using the same options and then compiling.
                • 5. Re: X5 Crashes during HTML compile
                  JayOyster Level 1
                  OK, no chums on a network drive. Check. And I've changed the output file name so it no longer uses an underscore. I restored a typo upstream in the help file working directory path that I had fixed before. I restored the entire help project folder and all subfolders from a January 11th backup (essentially the October working folder.) I named the Microsoft HTML Help.ssl file to Old-Microsoft HTML Help.ssl.

                  Then I opened the project, reset the Generate settings, and ran the compile. It reached the message 'Processing keywords...' and bombed again.
                  • 6. Re: X5 Crashes during HTML compile
                    JayOyster Level 1
                    I gave up trying to track down the source of the problem.

                    I started a fresh HTML help project, copied over all of the topics. Compiled. Success. Copied over the multimedia files. Compiled. Success.

                    I did that step-by-step for: glossary entries, CBEs, TOC, window design, ssl settings. So I'm about 95% back to where I was before this all started, and I've got all my new topics and content in place. I guess I'll just work from here as if it never happened. I'm a little leery of adding index keywords, since I have a sneaking suspicion that that was the source of my troubles, but I have no idea why that would be so.

                    Anyway . . . thanks for the help, Colum, Leon.

                    regards,
                    -Jay